Bug 1460617 - failed expects first param is a list when run upgrade_etcd.yml
failed expects first param is a list when run upgrade_etcd.yml
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jan Chaloupka
Anping Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 04:32 EDT by Anping Li
Modified: 2017-08-16 15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:26:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anping Li 2017-06-12 04:32:57 EDT
Description of problem:
run upgrade_etcd.yml failed.

Version-Release number of selected component (if applicable):
openshift-ansible-3.6.98

How reproducible:
always

Steps to Reproduce:
1. install OCP v3.6 with etcd-3.1.3-1.el7.x86_64
2. run playbook upgrade_etcd.yml

Actual results:
PLAYBOOK: upgrade_etcd.yml *****************************************************
17 plays in /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/upgrade_etcd.yml

PLAY [Create initial host groups for localhost] ********************************

TASK [include_vars] ************************************************************
task path: /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/initialize_groups.yml:10
ok: [localhost] => {
    "ansible_facts": {
        "g_all_hosts": "{{ g_master_hosts | union(g_node_hosts) | union(g_etcd_hosts) | union(g_lb_hosts) | union(g_nfs_hosts) | union(g_new_node_hosts)| union(g_new_master_hosts) | default([]) }}", 
        "g_etcd_hosts": "{{ groups.etcd | default([]) }}", 
        "g_glusterfs_hosts": "{{ groups.glusterfs | default([]) }}", 
        "g_glusterfs_registry_hosts": "{{ groups.glusterfs_registry | default(g_glusterfs_hosts) }}", 
        "g_lb_hosts": "{{ groups.lb | default([]) }}", 
        "g_master_hosts": "{{ groups.masters | default([]) }}", 
        "g_new_master_hosts": "{{ groups.new_masters | default([]) }}", 
        "g_new_node_hosts": "{{ groups.new_nodes | default([]) }}", 
        "g_nfs_hosts": "{{ groups.nfs | default([]) }}", 
        "g_node_hosts": "{{ groups.nodes | default([]) }}"
    }, 
    "changed": false
}

PLAY [Gate on etcd backup] *****************************************************

TASK [setup] *******************************************************************
ok: [localhost]

TASK [set_fact] ****************************************************************
task path: /usr/share/ansible/openshift-ansible/playbooks/common/openshift-cluster/upgrades/etcd/backup.yml:18
fatal: [localhost]: FAILED! => {
    "failed": true
}

MSG:

|failed expects first param is a list
	to retry, use: --limit @/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/upgrade_etcd.retry

PLAY RECAP *********************************************************************
localhost                  : ok=2    changed=0    unreachable=0    failed=1   


Expected results:


Additional info:
Comment 1 Scott Dodson 2017-06-26 09:48:05 EDT
Can this still be reproduced with current code?
Comment 2 Anping Li 2017-06-26 22:35:58 EDT
++ docker run -it -v /root/etcd-single:/root/workdir:rw -v /root/.ssh:/root/configdir:ro ose-ansible:v3.6 oo_play /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/upgrade_etcd.yml
atomic-openshift-utils-3.6.124-1.git.0.507a059.el7.noarch
ansible-playbook --private-key /root/configdir/libra.pem -i /root/workdir/hosts /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/upgrade_etcd.yml

PLAY [Create initial host groups for localhost] ********************************

TASK [include_vars] ************************************************************
ok: [localhost]

PLAY [Gate on etcd backup] *****************************************************

TASK [setup] *******************************************************************
ok: [localhost]

TASK [set_fact] ****************************************************************
fatal: [localhost]: FAILED! => {
    "failed": true
}

MSG:

|failed expects first param is a list
	to retry, use: --limit @/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/upgrade_etcd.retry

PLAY RECAP *********************************************************************
localhost                  : ok=2    changed=0    unreachable=0    failed=1
Comment 4 Jan Chaloupka 2017-06-28 07:26:35 EDT
Upstream PR: https://github.com/openshift/openshift-ansible/pull/4619
Comment 5 Jan Chaloupka 2017-06-28 08:12:26 EDT
Merged upstream
Comment 7 Anping Li 2017-07-03 22:46:08 EDT
The playbook succeed, so move to verified.
TASK [etcd_common : Display location of etcd backup] ***************************
ok: [openshift-208.lab.eng.nay.redhat.com] => {}

MSG:

Etcd backup created in /var/lib/etcd//openshift-backup-etcd_backup_tag20170704104444


PLAY [Gate on etcd backup] *****************************************************

TASK [setup] *******************************************************************
ok: [localhost]

TASK [set_fact] ****************************************************************
ok: [localhost]

TASK [set_fact] ****************************************************************
ok: [localhost]

TASK [fail] ********************************************************************
skipping: [localhost]

PLAY RECAP *********************************************************************
localhost                  : ok=18   changed=0    unreachable=0    failed=0   
openshift-208.lab.eng.nay.redhat.com : ok=80   changed=6    unreachable=0    failed=0
Comment 9 errata-xmlrpc 2017-08-10 01:26:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.