Bug 1460618 - lsmcli local-disk-list fails: LIB_BUG(1): BUG: Unexpected failure of _sg_io_mode_sense(): Got unknown sense data response code 38
lsmcli local-disk-list fails: LIB_BUG(1): BUG: Unexpected failure of _sg_io_...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libstoragemgmt (Show other bugs)
7.4
Unspecified Other
unspecified Severity medium
: rc
: ---
Assigned To: Gris Ge
Jakub Krysl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 04:37 EDT by Jakub Krysl
Modified: 2018-04-10 11:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: libstoragemgmt-1.5.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 11:36:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0864 None None None 2018-04-10 11:36 EDT

  None (edit)
Description Jakub Krysl 2017-06-12 04:37:12 EDT
Description of problem:
I cannot list the disks after connecting to NetApp array. Fails on s390x and ppc64 archs, on others it works.


Version-Release number of selected component (if applicable):
libstoragemgmt-1.4.0-3.el7.s390x


How reproducible:
100%

Steps to Reproduce:
1.connect to OnTap array
2.try to list local disk with "lsmcli local-disk-list"

Actual results:
LIB_BUG(1): BUG: Unexpected failure of _sg_io_mode_sense(): Got unknown sense data response code 38

Expected results:
List of disks

Additional info:
Comment 3 Gris Ge 2017-06-12 06:03:51 EDT
The `connecting to NetApp array` here means through iSCSI.
Comment 4 Gris Ge 2017-07-20 09:36:50 EDT
The issue was caused by bit field does not works on big-endian system.

Patch submitted to upstream:
https://github.com/libstorage/libstoragemgmt/pull/284
Comment 6 Jakub Krysl 2017-10-16 04:11:52 EDT
Fixed in libstoragemgmt-1.5.0-2.el7, 'lsmcli local-disk-list' to NetApp over iSCSI now lists local disks as it should.
Comment 9 errata-xmlrpc 2018-04-10 11:36:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0864

Note You need to log in before you can comment on or make changes to this bug.