Bug 1460619 - vdsm insert gaps in the ifcfg file for every network update
vdsm insert gaps in the ifcfg file for every network update
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.19.18
x86_64 Linux
medium Severity medium (vote)
: ovirt-4.1.4
: 4.19.21
Assigned To: Edward Haas
Michael Burman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 04:40 EDT by Michael Burman
Modified: 2017-07-28 10:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-28 10:10:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78890 master MERGED net: Unneeded newline is added when updating only the mtu 2017-07-03 08:28 EDT
oVirt gerrit 78900 ovirt-4.1 MERGED net: Unneeded newline is added when updating only the mtu 2017-07-04 03:59 EDT

  None (edit)
Description Michael Burman 2017-06-12 04:40:41 EDT
Description of problem:
vdsm insert gaps in the ifcfg file for every network update.

For every network update, for example MTU, vdsm insert new gap in the ifcfg file.
After few updates, you will have a huge gap in the ifcfg file.

For exmaple -

[root@orchid-vds2 ~]# cat /etc/sysconfig/network-scripts/ifcfg-mb1 
# Generated by VDSM version 4.19.17-1.el7ev
DEVICE=mb1
TYPE=Bridge
DELAY=0
STP=off
ONBOOT=yes
DEFROUTE=no
NM_CONTROLLED=no
IPV6INIT=no





MTU=1500[root@orchid-vds2 ~]# 
 

# Generated by VDSM version 4.19.17-1.el7ev
DEVICE=mb1
TYPE=Bridge
DELAY=0
STP=off
ONBOOT=yes
DEFROUTE=no
NM_CONTROLLED=no
IPV6INIT=no





MTU=1500


Version-Release number of selected component (if applicable):
vdsm-4.19.18-1.el7ev.x86_64
 4.1.3.2-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1. Attach network to host
2. Via 'Networks' tab update the network with custom MTU=9000
3. Update the network back to default MTU=1500
4. Continue steps 2 and 3 few times, update the network with MTU

Actual results:
Huge gap in the ifcfg-* file.
For every MTU update, new gap line is added in the ifcfg file

Expected results:
No gaps should be generated by vdsm into the ifcfg files
Comment 1 rhev-integ 2017-07-07 08:23:59 EDT
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Tag 'v4.19.21' doesn't contain patch 'https://gerrit.ovirt.org/78900']
gitweb: https://gerrit.ovirt.org/gitweb?p=vdsm.git;a=shortlog;h=refs/tags/v4.19.21

For more info please contact: infra@ovirt.org
Comment 2 Eyal Edri 2017-07-10 08:29:59 EDT
The patch is in the v4.19.21 tag and we've identified an issue with moving vdsm bugs to ON_QA on last build, the problem will be fixed by next build.
Comment 3 Michael Burman 2017-07-10 09:02:19 EDT
Verified on - vdsm-4.19.21-1.el7ev.x86_64

Note You need to log in before you can comment on or make changes to this bug.