Bug 1460679 - perl-HTML-FormFu-MultiForm-1.00-10.fc27 FTBFS randomly: Can't locate object method "tmp_upload_dir" via package "HTML::FormFu::QueryType::CGI"
perl-HTML-FormFu-MultiForm-1.00-10.fc27 FTBFS randomly: Can't locate object m...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-HTML-FormFu-MultiForm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1454506
  Show dependency treegraph
 
Reported: 2017-06-12 07:57 EDT by Petr Pisar
Modified: 2017-07-24 12:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-HTML-FormFu-MultiForm-1.00-11.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 12:09:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 91788 None None None 2017-06-12 07:57 EDT

  None (edit)
Description Petr Pisar 2017-06-12 07:57:55 EDT
perl-HTML-FormFu-MultiForm-1.00-10.fc27 fails to build in F27 randomly:

+ make test
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/*/*.t
Can't locate object method "tmp_upload_dir" via package "HTML::FormFu::QueryType::CGI" at /usr/share/perl5/vendor_perl/HTML/FormFu/UploadParam.pm line 45, <$fh> chunk 2, at /builddir/build/BUILD/HTML-FormFu-MultiForm-1.00/blib/lib/HTML/FormFu/MultiForm.pm line 508.
# Looks like your test exited with 255 just after 6.
t/multiform-misc-file-client-side.t .......... 
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 7/13 subtests 
t/multiform-misc/accessors.t ................. ok
Can't locate object method "tmp_upload_dir" via package "HTML::FormFu::QueryType::CGI" at /usr/share/perl5/vendor_perl/HTML/FormFu/UploadParam.pm line 45, <$fh> chunk 2, at /builddir/build/BUILD/HTML-FormFu-MultiForm-1.00/blib/lib/HTML/FormFu/MultiForm.pm line 508.
# Looks like your test exited with 255 just after 7.
t/multiform-misc/file-server-side.t .......... 
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 9/16 subtests
Comment 1 Petr Pisar 2017-07-24 11:46:50 EDT
I will remove the tests. I'm unable to find out where the bug is.

Note You need to log in before you can comment on or make changes to this bug.