This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1460687 - [RHEL 7.4] - When updating MTU to custom number and after that return to default MTU (1500) the network ifcfg file not updated
[RHEL 7.4] - When updating MTU to custom number and after that return to defa...
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.19.18
x86_64 Linux
medium Severity medium (vote)
: ovirt-4.1.4
: 4.19.22
Assigned To: Edward Haas
Michael Burman
: Automation, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 08:13 EDT by Ori Ben Sasson
Modified: 2017-07-28 10:10 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-28 10:10:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: blocker+


Attachments (Terms of Use)
logs (1.51 MB, application/zip)
2017-06-12 08:13 EDT, Ori Ben Sasson
no flags Details
vdsm and supervdsm logs (1.69 MB, application/zip)
2017-07-02 04:58 EDT, Meni Yakove
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79109 master MERGED net: Relocate DEFAULT_MTU costant to link.iface module 2017-07-07 05:00 EDT
oVirt gerrit 79110 master MERGED net: On MTU change to the default value update the ifcfg file 2017-07-07 05:00 EDT
oVirt gerrit 79161 ovirt-4.1 MERGED net: Relocate DEFAULT_MTU costant to link.iface module 2017-07-09 04:56 EDT
oVirt gerrit 79162 ovirt-4.1 MERGED net: On MTU change to the default value update the ifcfg file 2017-07-09 04:56 EDT

  None (edit)
Description Ori Ben Sasson 2017-06-12 08:13:45 EDT
Created attachment 1287046 [details]
logs

Description of problem:
When updating MTU to custom number and after that return to default MTU (1500) the network ifcfg file not updated on RHEL - 7.4 - 11.el7
by looking on engine side look like the MTU updated

Version-Release number of selected component (if applicable):
ovirt-engine-4.1.3.2-0.1.el7.noarch
vdsm-4.19.18-1.el7ev.x86_64
RHEL - 7.4 - 11.el7
Kernel Version - 3.10.0 - 663.el7.x86_64

How reproducible:
100

Steps to Reproduce:
1. Create and attach network to host with default MTU (1500)
2. Update the MTU to 9000
3. Update the MTU to 1500

Actual results:
The bridge ifcfg file not updated to 1500

Expected results:
The bridge ifcfg file should be updated to 1500

Additional info:
This bug occur only in RHEL - 7.4
Comment 1 Red Hat Bugzilla Rules Engine 2017-06-21 03:45:49 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Edward Haas 2017-07-02 04:18:59 EDT
Unfortunately, I'm unable to read the logs with so many networks defined there.
Please limit the scenario to one or two networks and share the logs again.

BTW: I suspect there is a 7.4 bug here regarding bond defaults.
It relates to the arp_ip_target default content.

arp_ip_target=216.124.160.62,51.152.255.255,185.170.104.145,255.255.255.255,56.125.160.62,51.152.255.255,15.157.201.145,255.255.255.255,16.0.0.0,51.152.255.255,72.125.160.62,51.152.255.255,8.125.160.62,51.152.255.255,111.242.37.235
Comment 3 Meni Yakove 2017-07-02 04:58 EDT
Created attachment 1293586 [details]
vdsm and supervdsm logs

Network name mtu_net
Comment 4 Edward Haas 2017-07-02 08:55:28 EDT
Thanks for the logs but I cannot see a problem from the logs.
After the setup is applied, a caps response is issued on 2017-07-02 11:53:55,538 which shows the correct MTU on the bridge.
Comment 5 Meni Yakove 2017-07-05 05:06:15 EDT
Only when setting back MTU to 1500 the ifcfg-<bridge-name> is not set to default MTU=1500

The physical interface is set to default MTU=1500 and /var/lib/vdsm/staging/netconf/nets/mtu_net is set to the currect MTU.

Need to fix the bridge ifcfg file to have the correct MTU.
Comment 6 Edward Haas 2017-07-06 11:25:51 EDT
On RLEH 7.4, when the bridge has no ports connected, it falls down to the default MTU.
The code has been adjusted to always write the bridge ifcfg file when the default mtu is set.
Comment 7 Michael Burman 2017-07-16 06:37:22 EDT
Verified on - vdsm-4.19.22-1.el7ev.x86_64 and
kernel-3.10.0-693.el7.x86_64
4.1.4.1-0.1.el7

Note You need to log in before you can comment on or make changes to this bug.