Bug 14607 - upgrade to rpm-4.0-0.56 from rpm-3.0.5-0.5 or rpm-3.0.4-0.48 failed
upgrade to rpm-4.0-0.56 from rpm-3.0.5-0.5 or rpm-3.0.4-0.48 failed
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-25 06:42 EDT by Bernhard Ege
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-25 06:42:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Ege 2000-07-25 06:42:24 EDT
Upgrading from rpm-3.0.5-0.5 to rpm-4.0-0.56 failed with the following
dependency problems:

rpm -Uvh rpm-4.0-0.56.i386.rpm 
error: failed dependencies:
	libbz2.so.1 is needed by rpm-4.0-0.56
	rpmlib(CompressedFileNames) <= 3.0.4-1 is needed by rpm-4.0-0.56

I added bzip2 to the upgrade, as well as a lot of rpm's that bzip would
breake and retried. I managed to remove all dependencies from the packages,
but ended up with these:

rpm -Uvh ImageMagick-* bzip2-1.0.1-2.i386.rpm rpm-4.0-0.56.i386.rpm
rpm-build-4.0-0.56.i386.rpm gnorpm-0.9-22.i386.rpm
chkfontpath-1.7.2-5.i386.rpm passwd-0.64.1-4.i386.rpm ucd-snmp-*
rpmfind-1.5-3.i386.rpm 
error: failed dependencies:
	rpmlib(PayloadFilesHavePrefix) <= 4.0-1 is needed by ImageMagick-5.2.2-4
	rpmlib(CompressedFileNames) <= 3.0.4-1 is needed by ImageMagick-5.2.2-4
	rpmlib(PayloadFilesHavePrefix) <= 4.0-1 is needed by
ImageMagick-devel-5.2.2-4
	rpmlib(CompressedFileNames) <= 3.0.4-1 is needed by
ImageMagick-devel-5.2.2-4
And so on...

I downgraded to rpm-3.0.4-0.48 and retried:

rpm -Uvh rpm-4.0-0.56.i386.rpm 
only packages with major numbers <= 3 are supported by this version of RPM
error: rpm-4.0-0.56.i386.rpm cannot be installed

Would --nodeps be safe to use in the former case (wouldn't help in the
latter).
Comment 1 Jeff Johnson 2000-07-25 09:46:25 EDT
The released rpm-3.0.5 knows how to satisy
	rpmlib(...)
feature dependencies, rpm-3.0.5-0.5 had not this functionality.

Adding --nodeps would probably permit upgrading rpm-3.0.5-0.5 ro rpm-4.0-0.56

Otherwise upgrade to rpm-3.0.5 packages
	ftp://ftp.rpm.org/pub/rpm/dist/3.0.x
in order to satsfy rpmlib(...) requirements.
Comment 2 Bernhard Ege 2000-07-26 03:49:44 EDT
Upgraded to rpm-3.0.5-7.6x.i386.rpm (latest on
ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/) and then upgraded further on to
rpm-4.0-0.56. The result is that rpm cannot see any installed packages:

"rpm -qa" results in nothing, no error, no packages. Querying a specific package
also results in nothing. My rpm database is still there as far as I can tell:

ls -l /var/lib/rpm
total 29577
-rw-r--r--    1 root     root        16384 Jul 26 09:37 conflictsindex.rpm
-rw-r--r--    1 root     root      5275648 Jul 26 09:37 fileindex.rpm
-rw-r--r--    1 root     root        16384 Jul 26 09:37 groupindex.rpm
-rw-r--r--    1 root     root        28672 Jul 26 09:37 nameindex.rpm
-rw-r--r--    1 root     root     25519304 Jul 26 09:37 packages.rpm
-rw-r--r--    1 root     root        90112 Jul 26 09:37 providesindex.rpm
-rw-r--r--    1 root     root       180224 Jul 26 09:37 requiredby.rpm
-rw-r--r--    1 root     root        16384 Jul 26 09:37 triggerindex.rpm

Something was not done by the rpm-4.0-0.56 post install script, but what might
that be?
Comment 3 Bernhard Ege 2000-07-26 07:33:05 EDT
On an additional note, running rpm with -vv results in this:

rpm -vv -qa
D: opening db index       /var/lib/rpm/Packages rdonly mode=0x0
D: closed  db index       /var/lib/rpm/Packages

Seems that rpm doesn't know the filenames of the rpm database files or that the
files weren't renamed to match?

Note You need to log in before you can comment on or make changes to this bug.