Bug 146070 - GDB+Kernel 2.6.10-1.741_FC3smp results in unkillable zombies
GDB+Kernel 2.6.10-1.741_FC3smp results in unkillable zombies
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-24 23:32 EST by David Shaw
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 04:16:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Shaw 2005-01-24 23:32:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
Debugging a threaded program with gdb 6.1post-1.20040607.43 and kernel
2.6.10-1.741_FC3smp results in a gdb lockup.  At this point if you
kill -9 gdb, then the process that you were debugging becomes an
unkillable zombie.  The process is inherited by by init - it just
won't die despite a kill -9.

Not using NPTL (via LD_ASSUME_KERNEL=2.2.5 or -rpath to force the
older linuxthreads) makes the problem go away.

I have tried this with 2.6.9-1.667 and 2.6.10-1.741_FC3 both with and
without smp with the same results.

Related?: 
http://www.gelato.unsw.edu.au/linux-ia64/0407/10420.html
http://marc.theaimsgroup.com/?l=linux-kernel&m=108857533723068&w=2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. gdb my_threaded_program
2. kill -9 gdb
3.
    

Actual Results:  'my_threaded_program' became an unkillable zombie

Additional info:
Comment 1 Dave Jones 2005-07-15 13:45:57 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.