Bug 1460718 - The default log level 16384 is stripped from the log level returned to a client.
The default log level 16384 is stripped from the log level returned to a client.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.4
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: mreynolds
Viktor Ashirov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 09:44 EDT by Viktor Ashirov
Modified: 2018-04-10 10:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.7.5-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 10:16:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0811 None None None 2018-04-10 10:17 EDT

  None (edit)
Description Viktor Ashirov 2017-06-12 09:44:52 EDT
This is a continuation of bz1441790

I set log level to 65536+16384+8192+128=90240, but ldapsearch returns 73856 (90240-16384). In dse.ldif there is a correct value.

So default loglevel is always subtracted no matter what.

Another issue. After setting log level 64 or 1 in dse.ldif, I get this message in the errors logs: 
[29/May/2017:15:19:09.972284013 +0200] - NOTICE - slapd_bootstrap_config - nsslapd-errorlog-level: ignoring 64 (since -d 266354688 was given on the command line)

but parameter -d is not given on the command line:
# ps -ef | grep [n]s-slapd
dirsrv   14511     1  0 15:20 ?        00:00:02 /usr/sbin/ns-slapd -D /etc/dirsrv/slapd-master_1 -i /var/run/dirsrv/slapd-master_1.pid
dirsrv   14876     1  0 15:22 ?        00:00:00 /usr/sbin/ns-slapd -D /etc/dirsrv/slapd-master_2 -i /var/run/dirsrv/slapd-master_2.pid
Comment 2 Viktor Ashirov 2017-11-06 08:55:26 EST
===================================================================== test session starts =====================================================================
platform linux -- Python 3.5.1, pytest-3.2.3, py-1.4.34, pluggy-0.4.0 -- /opt/rh/rh-python35/root/usr/bin/python3
cachedir: .cache
metadata: {'Packages': {'pytest': '3.2.3', 'pluggy': '0.4.0', 'py': '1.4.34'}, 'Python': '3.5.1', 'Plugins': {'metadata': '1.5.0', 'html': '1.16.0'}, 'Platform': 'Linux-3.10.0-765.el7.x86_64-x86_64-with-redhat-7.5-Maipo'}
389-ds-base: 1.3.7.5-9.el7
nss: 3.34.0-0.1.beta1.el7
nspr: 4.17.0-1.el7
openldap: 2.4.44-5.el7
svrcore: 4.1.3-2.el7

rootdir: /export/tests, inifile:
plugins: metadata-1.5.0, html-1.16.0
collected 4 items                                                                                                                                              

suites/ds_logs/regression_test.py::test_default_loglevel_stripped[24576] PASSED
suites/ds_logs/regression_test.py::test_default_loglevel_stripped[16512] PASSED
suites/ds_logs/regression_test.py::test_default_loglevel_stripped[16385] PASSED
suites/ds_logs/regression_test.py::test_dse_config_loglevel_error PASSED

------------------------------------------------ generated xml file: /mnt/tests/rhds/tests/upstream/report.xml ------------------------------------------------
----------------------------------------------- generated html file: /mnt/tests/rhds/tests/upstream/report.html -----------------------------------------------
================================================================== 4 passed in 19.06 seconds ==================================================================


Automated tests pass, marking as VERIFIED.
Comment 5 errata-xmlrpc 2018-04-10 10:16:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0811

Note You need to log in before you can comment on or make changes to this bug.