Bug 146072 - Memory leak when create or copy large files
Summary: Memory leak when create or copy large files
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
Assignee: Larry Woodman
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-25 05:24 UTC by Dimitris
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-07 13:57:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
As3 info rar file (103.18 KB, application/octet-stream)
2005-01-25 05:33 UTC, Dimitris
no flags Details
vmstat output (21.17 KB, application/octet-stream)
2005-01-27 13:58 UTC, Dimitris
no flags Details

Description Dimitris 2005-01-25 05:24:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040514

Description of problem:
When create or copy large file >= 6gb I have a memory leak !
I use a IBM e236 with 2 opteron processors and 4 gb mem + qla2340 +
ibm storage fast600!
I look the top command and the cp process use all the memory !!
I have create swap space 4 gb but in the top command no swap space used!


Version-Release number of selected component (if applicable):
kernel-2.4.21-27.0.1.ELsmp

How reproducible:
Always

Steps to Reproduce:
1.cp largefile from storage to local (mirror) disk
2.
3.
    

Actual Results:  system very low performance

Additional info:

Comment 1 Dimitris 2005-01-25 05:33:43 UTC
Created attachment 110181 [details]
As3 info rar file

Here is some information about the system settings

Comment 2 Larry Woodman 2005-01-26 14:20:49 UTC
Dimitris, please provide more information here.  Please start by
running "vmstat 1" while the copy is taking place and attach the
results.  

RHEL3 uses system memory to cache the file system data when you
reference file pages so its is likely that the system is still holding
onto that memory for that purpose.

Larry Woodman


Comment 3 Dimitris 2005-01-27 13:58:42 UTC
Created attachment 110298 [details]
vmstat output

Comment 4 Larry Woodman 2005-01-27 16:58:12 UTC
Dimitris, thanks for the vmstat output.  I dont see a problem with the
kernel, its working as it is designed.  Before starting the copy you
have ~1.5GB in the pagecache and ~1.5GB free.  After the copy you have
~3GB in the pagecache and the system has not swapped at all. 

VMSTAT output.......................
r  b   swpd   free   buff  cache 
1  1      0 1542952 211060 1555064
...
0  0      0  20356 221816 3055976
....................................

The Linux kernel uses all available memory to cache filesystem data so
that it wont have to do disk IO if that file data is needed again in
the near future.  Since it can and does reclaim those pages out of the
file system cache its not leaking memory, its just using it appropriately.

Do you agree or is there some other problem that I am not
understanding here?


Thanks, Larry Woodman



Note You need to log in before you can comment on or make changes to this bug.