Bug 1460737 - rubygem-fluent-plugin-parser: fluentd plugin parser
rubygem-fluent-plugin-parser: fluentd plugin parser
Status: CLOSED WONTFIX
Product: RDO
Classification: Community
Component: Package Review (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: trunk
Assigned To: Matthias Runge
hguemar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 10:45 EDT by Juan Badia Payno
Modified: 2017-08-08 10:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-08 10:24:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mrunge: rdo‑review+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
RDO 7478 None None None 2017-07-08 11:53 EDT

  None (edit)
Comment 1 Matthias Runge 2017-06-15 05:34:25 EDT
this looks ok to me, please change the requires from rubygem-oj to rubygem(oj).

This here should fix the missing provides: https://review.rdoproject.org/r/#/c/7070/
Comment 2 Juan Badia Payno 2017-06-19 03:18:18 EDT
Fixed the rubygem-oj to rubygem(oj)

Added some dependencies that were missed.
Comment 3 Matthias Runge 2017-06-19 04:20:51 EDT
note, there is no rubygem-rake, no rubygem-bundler, and no rubygem-json in cbs yet.
Comment 4 Juan Badia Payno 2017-07-06 02:52:01 EDT
The three packages are on centos 7 base repository, at least I could see them on:
[vagrant@rpmbuild ~]$ yum list rubygem* | egrep -e json -e rake -e bundler 
rubygem-bundler.noarch               1.7.8-3.el7        @base                   
rubygem-json.x86_64                  1.7.7-29.el7       @base                   
rubygem-rake.noarch                  0.9.6-29.el7       @base 
Note: my base repo points at mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os&infra=$infra

I could see them on cbs as:
rubygem-bundler -- http://cbs.centos.org/koji/rpminfo?rpmID=59525
rubygem-json    -- http://cbs.centos.org/koji/search?match=glob&type=rpm&terms=rubygem-json*
rubygem-rake    -- http://cbs.centos.org/koji/search?match=glob&type=rpm&terms=rubygem-rake*
Comment 5 Matthias Runge 2017-07-06 10:45:53 EDT
Since you want to have this built against all 0.12.x versions, make the requirement
BuildRequires: fluentd < 0.12.31
more something like
(either)
BuildRequires: fluentd 
or 
BuildRequires: fluentd < 0.13

There won't be a fluentd > 0.12.x any time soon in cbs, I guess. 

Otherwise looks good, the license specified is correct. Please fix the BuildRequires during import.
Comment 6 Matthias Runge 2017-07-08 11:53:16 EDT
https://review.rdoproject.org/r/#/c/7478/

Note You need to log in before you can comment on or make changes to this bug.