Bug 1460780 - Re-Run failed remote execution task for single content host takes 'Host Collection' instead of single content host.
Re-Run failed remote execution task for single content host takes 'Host Colle...
Status: CLOSED DUPLICATE of bug 1386192
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Remote Execution (Show other bugs)
6.2.9
All Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 13:26 EDT by Varatharaja Perumal G
Modified: 2017-06-13 06:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-13 03:53:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Varatharaja Perumal G 2017-06-12 13:26:51 EDT
Description of problem:

When we run a remote execution job for multiple content host through 'Host Collection'. When we re-run the remote execution for single content host it takes 'Host Collection' instead of single content host.

Version-Release number of selected component (if applicable):
Satellite 6.2.9

How reproducible:


Steps to Reproduce:
1. Create a 'Host Collection' with multiple content host.
2. Run the remote execution task for the 'Host Collection'
3. On the remote execution result screen. Select Hosts tab.
4. Hosts --> Select (host) --> Action -->  drop down -> Rerun (host)
5. It will take the 'Host Collection' instead of selected host.

Actual results:

It take 'Host Collection' instead of single host to run the job.

Expected results:

It should run for single host instead of 'Host Collection'

Additional info:
Comment 2 Varatharaja Perumal G 2017-06-12 13:30 EDT
Created attachment 1287080 [details]
Host collection
Comment 3 Varatharaja Perumal G 2017-06-12 13:32 EDT
Created attachment 1287081 [details]
Host collection
Comment 5 aruzicka 2017-06-13 03:53:44 EDT
Even though this BZ isn't an exact duplicate of the linked one, they share the same root cause.

*** This bug has been marked as a duplicate of bug 1386192 ***

Note You need to log in before you can comment on or make changes to this bug.