This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 146086 - gnome-bluetooth-manager: illegal configuration key
gnome-bluetooth-manager: illegal configuration key
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
n/a
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-25 05:23 EST by MIchael Kolmodin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-31 06:41:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description MIchael Kolmodin 2005-01-25 05:23:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10.1

Description of problem:
gnome-bluetooth-manager: illegal configuration key, nothing happens
when clicking on "Properties".

Hunting down other problems I've noted that gnome-bluetooth-manager
tries to create a configuration directory named "Gnome Bluetooth
Manager". gconfd rejects this request since the key contains blanks.
The message at console when starting the application is:

(Bluetooth Device Manager:20523): GConf-CRITICAL **: file
gconf-client.c: line 553 (gconf_client_add_dir): assertion
`gconf_valid_key (dirname, NULL)' failed

I suspect that this is related to the fact that nothing happens when I
click on the "Properties" menu entry.

I also think that there should be a bug filed on gconfd for this: it
rejects the configuration key without any type of info like logging
etc. I've verified this in the source. Will not file such a bug
though; I've the necessary diffs to enable logging by now :-)



Version-Release number of selected component (if applicable):
gnome-bluetooth-0.5.1-5.FC3.1

How reproducible:
Always

Steps to Reproduce:
1.Start gnome-bluetooth-manager in terminal window.
2. See error message (above)
3. Click on the "Edit | Properties" menu entry

    

Actual Results:  Nothing

Expected Results:  No error printout, a Properties window displayed.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.