Bug 1460864 - Menu items are not context aware for Ceph and Gluster [RFE]
Menu items are not context aware for Ceph and Gluster [RFE]
Status: CLOSED DUPLICATE of bug 1461137
Product: Red Hat Storage Console
Classification: Red Hat
Component: Dashboard (Show other bugs)
3
x86_64 Linux
high Severity high
: beta
: 3
Assigned To: Neha Gupta
sds-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 21:49 EDT by Jeff Applewhite
Modified: 2017-06-15 10:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-15 10:33:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Applewhite 2017-06-12 21:49:25 EDT
Description of problem:
The menu items in console 3 show items that are not pertinent to the storage backend

Version-Release number of selected component (if applicable):
3 alpha

How reproducible:
always

Steps to Reproduce:
1. view menus
2.
3.

Actual results:


Expected results:
see
https://github.com/Tendrl/dashboard/issues/424
Please update all the "File Share" references in the UI to "Volume" in the UI. This includes the following:

Menu item for "Volumes"
Volumes List view
Create Volume
Edit Volume
Delete Volume
Rebalance Volume
Start / Stop Volume
Object Details view where there is a "Volume" tab (e.g. Gluster cluster object details
Any tooltip with the "volume" reference
Specifically, if I'm a Gluster user, I may get confused by the "File Share" reference as all Gluster documentation references the term "Volume" and we will want to be consistent with Gluster terminology.

Additional info:
Comment 3 Ju Lim 2017-06-15 10:25:37 EDT
This is actually 2 BZ's:

(1) Address context-sensitive menus and navigation (and dashboard) -- see BZ 1461876.

(2) Relabeling "File share" to "Volume" -- see BZ 1461137
Comment 4 Jeff Applewhite 2017-06-15 10:33:07 EDT

*** This bug has been marked as a duplicate of bug 1461137 ***

Note You need to log in before you can comment on or make changes to this bug.