Bug 1460871 - Installation failed on GCE by task openshift_default_storage_class : Ensure storageclass object
Installation failed on GCE by task openshift_default_storage_class : Ensure s...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Hemant Kumar
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 22:30 EDT by Weihua Meng
Modified: 2017-08-10 01:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:26:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Weihua Meng 2017-06-12 22:30:25 EDT
Description of problem:
Installation failed on GCE by task openshift_default_storage_class : Ensure storageclass object

Version-Release number of selected component (if applicable):
openshift-ansible-3.6.99-1.git.0.42f2439.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. Install OCP on GCE by openshift-ansible

Actual results:
Installation Failed.
TASK [openshift_default_storage_class : Ensure storageclass object] ************
Tuesday 13 June 2017  00:57:36 +0000 (0:00:00.568)       0:26:04.572 ********** 
fatal: [qe-wmeng36-master-nfs-1.0613-a6s.qe.rhcloud.com]: FAILED! => {
    "failed": true
}

MSG:

the field 'args' has an invalid value, which appears to include a variable that is undefined. The error was: {{ openshift_storageclass_defaults[openshift_cloudprovider_kind]['provisioner'] }}: 'dict object' has no attribute u'gce'

The error appears to have been in '/home/slave3/workspace/Launch Environment Flexy/private-openshift-ansible/roles/openshift_default_storage_class/tasks/main.yml': line 3, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

# Install default storage classes in GCE & AWS
- name: Ensure storageclass object
  ^ here



NO MORE HOSTS LEFT *************************************************************
Expected results:
Installation success

Additional info:
Comment 1 Weihua Meng 2017-06-12 22:33:46 EDT
Issue addressed in https://github.com/openshift/openshift-ansible/issues/4405
Comment 2 Scott Dodson 2017-06-13 10:56:04 EDT
pull request already merged

https://github.com/openshift/openshift-ansible/pull/4407
Comment 4 Weihua Meng 2017-06-14 01:59:26 EDT
Verified with openshift-ansible-3.6.100-1.git.0.08e52a1.el7.noarch.rpm
Fixed.

Installation SUCCESS

TASK [openshift_default_storage_class : Ensure storageclass object] ************
Wednesday 14 June 2017  01:22:53 +0000 (0:00:00.557)       0:26:07.842 ******** 
changed: [qe-wmeng36-master-nfs-1.0614-whd.qe.rhcloud.com] => {
    "changed": true, 
    "results": {
        "cmd": "/usr/bin/oc get storageclass standard -o json -n default", 
        "results": [
            {
                "apiVersion": "storage.k8s.io/v1", 
                "kind": "StorageClass", 
                "metadata": {
                    "annotations": {
                        "storageclass.beta.kubernetes.io/is-default-class": "true"
                    }, 
                    "creationTimestamp": "2017-06-14T01:22:54Z", 
                    "name": "standard", 
                    "resourceVersion": "1629", 
                    "selfLink": "/apis/storage.k8s.io/v1/storageclasses/standard", 
                    "uid": "fdd68244-509f-11e7-8b5a-42010af00002"
                }, 
                "parameters": {
                    "type": "pd-standard"
                }, 
                "provisioner": "kubernetes.io/gce-pd"
            }
        ], 
        "returncode": 0
    }, 
    "state": "present"
}
Comment 6 errata-xmlrpc 2017-08-10 01:26:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.