Bug 1460875 - [paid][online-stg]Metrics does not work
[paid][online-stg]Metrics does not work
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Metrics (Show other bugs)
3.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Stefanie Forrester
Junqi Zhao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 22:53 EDT by Junqi Zhao
Modified: 2017-11-09 13:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-09 13:57:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"Application is not available" error for metrics route (73.89 KB, image/png)
2017-06-12 22:53 EDT, Junqi Zhao
no flags Details

  None (edit)
Description Junqi Zhao 2017-06-12 22:53:13 EDT
Created attachment 1287138 [details]
"Application is not available" error for metrics route

Description of problem:
Try to access https://metrics.online-stg.openshift.com/hawkular/metrics, "Application is not available" error shows

Version-Release number of selected component (if applicable):
3.5.5.25
online version:3.5.1.32

How reproducible:
Always

Steps to Reproduce:
1. Login https://metrics.online-stg.openshift.com/hawkular/metrics

Actual results:
"Application is not available" error shows

Expected results:
Could be accessed normally

Additional info:
Comment 1 Junqi Zhao 2017-06-12 23:25:42 EDT
hawkular-metrics pod is not in running status
Command ***** oc get pod -n openshift-infra ***** result as below:
 
NAME                               READY     STATUS              RESTARTS   AGE
hawkular-cassandra-1-f1vxg         1/1       Running             6          25d
hawkular-cassandra-2-jjl55         0/1       ContainerCreating   0          11d
hawkular-metrics-dwzmb             0/1       CrashLoopBackOff    499        11d
heapster-rwtbl                     0/1       Running             541        25d
online-stg-account-2-m4583         1/1       Running             0          4h
online-stg-notifications-4-8f6jg   1/1       Running             0          4h
online-user-analytics-4-zks17      1/1       Running             1          4h
Comment 2 Stefanie Forrester 2017-06-14 12:39:26 EDT
Redeployed metrics. It seems to be staying up this time.
Comment 3 Junqi Zhao 2017-06-14 20:21:09 EDT
https://metrics.online-stg.openshift.com/hawkular/metrics could be accessed, and CPU, Memory and Network usage can be viewed from web console.

OpenShift Master:v3.5.5.26 (online version 3.5.1.34)
Kubernetes Master:v1.5.2+43a9be4 


Command ***** oc get pod -n openshift-infra ***** result as below:
 
NAME                               READY     STATUS    RESTARTS   AGE
hawkular-cassandra-1-p9hl1         1/1       Running   0          1d
hawkular-cassandra-2-gns9r         1/1       Running   2          1d
hawkular-metrics-b7r0s             1/1       Running   2          1d
heapster-h5mrt                     1/1       Running   2          1d

Note You need to log in before you can comment on or make changes to this bug.