Bug 1460925 - identity service v3 api_extensions URL page not found
identity service v3 api_extensions URL page not found
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest (Show other bugs)
10.0 (Newton)
x86_64 Linux
urgent Severity high
: z4
: 10.0 (Newton)
Assigned To: Martin Kopec
Chandan Kumar
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-13 03:37 EDT by Dev
Modified: 2017-09-06 13:06 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-tempest-13.0.0-14.bafe630git.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-06 13:06:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tempest.conf from the Cu environment (5.32 KB, text/plain)
2017-06-19 06:22 EDT, Ganesh Kadam
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
RDO 7091 None None None 2017-06-15 11:59 EDT
Gerrithub.io 365670 None None None 2017-06-15 11:38 EDT

  None (edit)
Description Dev 2017-06-13 03:37:38 EDT
Description of problem:
attempting to configure tempest to run on an OSP deployment that includes keystone v3 and SSO authentication. 
When running the tools/config_tempest.py to configure tempest, get error that the python script couldnt find the https://cloudname/v3/v2.0/extensions Page not found.
What I noticed was the the api_extensions script was appending v2.0/extensions to the URL. 
the v3/extensions did not exist at all. 

Version-Release number of selected component (if applicable):
RH OSP 10 
openstack-tempest-13.0.0-10.bafe630git.el7ost.noarch
RHEL 7.3

How reproducible:
every time

Steps to Reproduce:
1. run the tools/config_tempest.py --deployer-input /home/stack/git/osp_config/environments/v-cw-1-1/tempest-deployer-input.conf --debug --create identity.uri $OS_AUTH_URL identity.admin_password $OS_PASSWORD network.tenant_network_cidr 192.168.0.0/24 --network-id $pubnet --image /home/stack/cirros-0.3.5-x86_64-disk.img
2.
3.

Actual results:
2017-06-13 16:42:19.947 5160 INFO tempest [-] Using tempest config file /home/stack/tempest/etc/tempest.conf
2017-06-13 16:42:20.124 5160 INFO __main__ [-] Reading defaults from file '/home/stack/tempest/etc/default-overrides.conf'
2017-06-13 16:42:20.124 5160 INFO __main__ [-] Adding options from deployer-input file '/home/stack/git/osp_config/environments/v-cw-1-1/tempest-deployer-input.conf'
2017-06-13 16:42:20.125 5160 DEBUG __main__ [-] Setting [auth] tempest_roles = swiftoperator set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.125 5160 DEBUG __main__ [-] Setting [compute] region = regionOne set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.125 5160 DEBUG __main__ [-] Setting [compute-feature-enabled] console_output = false set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.126 5160 DEBUG __main__ [-] Setting [identity] region = regionOne set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.126 5160 DEBUG __main__ [-] Setting [identity] uri_v3 = https://clvcw1ov101.uae-dev.cmn-model.corp.telstra.com:13000/v3 set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.126 5160 DEBUG __main__ [-] Setting [identity] admin_password = eDWMqV68Zck4Ac2WktBpq3B2u set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.126 5160 DEBUG __main__ [-] Setting [identity-feature-enabled] api_v2 = False set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.126 5160 DEBUG __main__ [-] Setting [identity-feature-enabled] api_v3 = False set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.126 5160 DEBUG __main__ [-] Setting [image] region = regionOne set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.126 5160 DEBUG __main__ [-] Setting [network] region = regionOne set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.127 5160 DEBUG __main__ [-] Setting [object-storage] operator_role = swiftoperator set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.127 5160 DEBUG __main__ [-] Setting [object-storage] region = regionOne set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.127 5160 DEBUG __main__ [-] Setting [orchestration] stack_owner_role = swiftoperator set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.127 5160 DEBUG __main__ [-] Setting [orchestration] region = regionOne set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.127 5160 DEBUG __main__ [-] Setting [volume] backend1_name = tripleo_iscsi set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.127 5160 DEBUG __main__ [-] Setting [volume] region = regionOne set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.127 5160 DEBUG __main__ [-] Setting [volume-feature-enabled] bootable = true set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.128 5160 DEBUG __main__ [-] Setting [identity] uri = https://clvcw1ov101.uae-dev.cmn-model.corp.telstra.com:13000/v3 set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.128 5160 DEBUG __main__ [-] Setting [identity] admin_password = eDWMqV68Zck4Ac2WktBpq3B2u set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.128 5160 DEBUG __main__ [-] Setting [network] tenant_network_cidr = 192.168.0.0/24 set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.128 5160 DEBUG __main__ [-] Setting [identity] auth_version = v3 set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.128 5160 DEBUG __main__ [-] Setting [identity] uri = https://clvcw1ov101.uae-dev.cmn-model.corp.telstra.com:13000/v2.0 set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:20.128 5160 DEBUG __main__ [-] Option '[identity] uri_v3 = https://clvcw1ov101.uae-dev.cmn-model.corp.telstra.com:13000/v3' was defined by user, NOT overwriting into value 'https://clvcw1ov101.uae-dev.cmn-model.corp.telstra.com:13000/v3' set /home/stack/tempest/tools/config_tempest.py:464
2017-06-13 16:42:20.374 5160 INFO tempest.lib.common.rest_client [req-c71cd559-b393-4017-91ff-e6bd6d50b23c ] Request (main): 200 POST https://clvcw1ov101.uae-dev.cmn-model.corp.telstra.com:13000/v2.0/tokens
2017-06-13 16:42:20.396 5160 INFO tempest.lib.common.rest_client [req-af30beba-d22b-4b58-9f96-dedd3293471a ] Request (main): 200 GET http://172.31.19.6:35357/v2.0/tenants 0.021s
2017-06-13 16:42:20.396 5160 DEBUG __main__ [-] Setting [identity] admin_tenant_id = 0380f6400472464cbf643052ec89dedd set /home/stack/tempest/tools/config_tempest.py:468
2017-06-13 16:42:24.337 5160 CRITICAL tempest [-] ServiceError: Request on service 'identity' with url 'https://clvcw1ov101.uae-dev.cmn-model.corp.telstra.com:13000/v3/extensions' failed with code 404
2017-06-13 16:42:24.337 5160 ERROR tempest Traceback (most recent call last):
2017-06-13 16:42:24.337 5160 ERROR tempest   File "/home/stack/tempest/tools/config_tempest.py", line 850, in <module>
2017-06-13 16:42:24.337 5160 ERROR tempest     main()
2017-06-13 16:42:24.337 5160 ERROR tempest   File "/home/stack/tempest/tools/config_tempest.py", line 166, in main
2017-06-13 16:42:24.337 5160 ERROR tempest     'disable_ssl_certificate_validation'
2017-06-13 16:42:24.337 5160 ERROR tempest   File "/home/stack/tempest/tempest/common/api_discovery.py", line 207, in discover
2017-06-13 16:42:24.337 5160 ERROR tempest     services[name]['extensions'] = service.get_extensions()
2017-06-13 16:42:24.337 5160 ERROR tempest   File "/home/stack/tempest/tempest/common/api_discovery.py", line 112, in get_extensions
2017-06-13 16:42:24.337 5160 ERROR tempest     body = self.do_get(self.service_url + '/extensions')
2017-06-13 16:42:24.337 5160 ERROR tempest   File "/home/stack/tempest/tempest/common/api_discovery.py", line 61, in do_get
2017-06-13 16:42:24.337 5160 ERROR tempest     " with code %d" % (self.name, url, r.status))
2017-06-13 16:42:24.337 5160 ERROR tempest ServiceError: Request on service 'identity' with url 'https://clvcw1ov101.uae-dev.cmn-model.corp.telstra.com:13000/v3/extensions' failed with code 404
2017-06-13 16:42:24.337 5160 ERROR tempest
rm: cannot remove ‘saved_state.json’: No such file or directory
2017-06-13 16:42:24.756 5188 INFO tempest [-] Using tempest config file /home/stack/tempest/etc/tempest.conf
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup [-] Failure during cleanup
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup Traceback (most recent call last):
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup   File "/usr/lib/python2.7/site-packages/tempest/cmd/cleanup.py", line 75, in take_action
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup     self.init(parsed_args)
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup   File "/usr/lib/python2.7/site-packages/tempest/cmd/cleanup.py", line 86, in init
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup     self.admin_mgr = credentials.AdminManager()
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup   File "/usr/lib/python2.7/site-packages/tempest/common/credentials_factory.py", line 228, in __init__
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup     credentials=get_configured_admin_credentials(),
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup   File "/usr/lib/python2.7/site-packages/tempest/common/credentials_factory.py", line 185, in get_configured_admin_credentials
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup     identity_version=identity_version, **params)
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup   File "/usr/lib/python2.7/site-packages/tempest/common/credentials_factory.py", line 218, in get_credentials
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup     **params)
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup   File "/usr/lib/python2.7/site-packages/tempest/lib/auth.py", line 644, in get_credentials
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup     http_timeout=http_timeout)
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup   File "/usr/lib/python2.7/site-packages/tempest/lib/auth.py", line 265, in __init__
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup     super(KeystoneAuthProvider, self).__init__(credentials, scope)
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup   File "/usr/lib/python2.7/site-packages/tempest/lib/auth.py", line 93, in __init__
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup     raise exceptions.InvalidCredentials(message)
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup InvalidCredentials: Invalid Credentials
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup Details: Credentials are: {'username': None, 'project_name': None, 'user_id': None, 'tenant_name': None, 'tenant_id': None, 'project_id': None} Password is not defined.
2017-06-13 16:42:24.897 5188 ERROR tempest.cmd.cleanup
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest/cmd/cleanup.py", line 75, in take_action
    self.init(parsed_args)
  File "/usr/lib/python2.7/site-packages/tempest/cmd/cleanup.py", line 86, in init
    self.admin_mgr = credentials.AdminManager()
  File "/usr/lib/python2.7/site-packages/tempest/common/credentials_factory.py", line 228, in __init__
    credentials=get_configured_admin_credentials(),
  File "/usr/lib/python2.7/site-packages/tempest/common/credentials_factory.py", line 185, in get_configured_admin_credentials
    identity_version=identity_version, **params)
  File "/usr/lib/python2.7/site-packages/tempest/common/credentials_factory.py", line 218, in get_credentials
    **params)
  File "/usr/lib/python2.7/site-packages/tempest/lib/auth.py", line 644, in get_credentials
    http_timeout=http_timeout)
  File "/usr/lib/python2.7/site-packages/tempest/lib/auth.py", line 265, in __init__
    super(KeystoneAuthProvider, self).__init__(credentials, scope)
  File "/usr/lib/python2.7/site-packages/tempest/lib/auth.py", line 93, in __init__
    raise exceptions.InvalidCredentials(message)
InvalidCredentials: Invalid Credentials
Details: Credentials are: {'username': None, 'project_name': None, 'user_id': None, 'tenant_name': None, 'tenant_id': None, 'project_id': None} Password is not defined.
2017-06-13 16:42:24.898 5188 ERROR tempest [-] Invalid Credentials
Details: Credentials are: {'username': None, 'project_name': None, 'user_id': None, 'tenant_name': None, 'tenant_id': None, 'project_id': None} Password is not defined.
rm: cannot remove ‘tempest.log’: No such file or directory
[stack@lxvcw1di101 post-deployment-scripts]$

Expected results:
should configure ~/tempest/etc/tempest.conf without any errors

Additional info:

I had to modify the /home/stack/tempest/tempest/common/api_discovery.py 
LINE # 111
FROM :             body = self.do_get(self.service_url + '/v2.0/extensions')
TO:            body = self.do_get('https://clvcw1ov101.uae-dev.cmn-model.corp.telstra.com:13000/v2.0/extensions')
.. to get over the issue and proceed.
Comment 1 Red Hat Bugzilla Rules Engine 2017-06-16 10:21:52 EDT
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.
Comment 3 Ganesh Kadam 2017-06-19 06:22 EDT
Created attachment 1289058 [details]
tempest.conf from the Cu environment
Comment 7 Chandan Kumar 2017-08-16 23:40:14 EDT
openstack-tempest-13.0.0-14.bafe630git.el7ost package contains the fixes for the same and it works as expected. So moving to it to verified.
Comment 9 errata-xmlrpc 2017-09-06 13:06:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2653

Note You need to log in before you can comment on or make changes to this bug.