Bug 1461018 - Implement DISCARD FOP for EC
Implement DISCARD FOP for EC
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
mainline
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Sunil Kumar Acharya
:
Depends On:
Blocks: 1499865
  Show dependency treegraph
 
Reported: 2017-06-13 07:23 EDT by Sunil Kumar Acharya
Modified: 2017-12-08 12:33 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.13.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1499865 (view as bug list)
Environment:
Last Closed: 2017-12-08 12:33:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sunil Kumar Acharya 2017-06-13 07:23:26 EDT
Adding discard functionality to EC.
Comment 1 Worker Ant 2017-07-14 06:46:37 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#1) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 2 Worker Ant 2017-07-18 09:16:03 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#2) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 3 Worker Ant 2017-07-19 06:48:22 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#3) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 4 Worker Ant 2017-07-19 07:52:21 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#4) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 5 Worker Ant 2017-07-21 11:42:00 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#5) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 6 Worker Ant 2017-07-25 11:56:24 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#6) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 7 Worker Ant 2017-08-01 03:22:06 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#7) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 8 Worker Ant 2017-08-24 02:59:28 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#8) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 9 Worker Ant 2017-09-28 08:40:27 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#9) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 10 Worker Ant 2017-10-09 10:35:55 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#10) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 11 Worker Ant 2017-10-09 11:17:12 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#11) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 12 Worker Ant 2017-10-13 09:33:06 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#12) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 13 Worker Ant 2017-10-18 07:52:42 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#13) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 14 Worker Ant 2017-10-23 09:26:19 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#14) for review on master by Sunil Kumar Acharya (sheggodu@redhat.com)
Comment 15 Worker Ant 2017-10-25 05:55:37 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#15) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 16 Worker Ant 2017-10-25 07:31:34 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#16) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 17 Worker Ant 2017-10-25 07:52:51 EDT
REVIEW: https://review.gluster.org/17777 (cluster/ec: Implement DISCARD FOP for EC) posted (#17) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 18 Worker Ant 2017-10-25 14:56:19 EDT
COMMIT: https://review.gluster.org/17777 committed in master by Xavier Hernandez (jahernan@redhat.com) 
------
commit 63160cb952fe7716a3313ce5ee32f890fe4d7a0c
Author: Sunil Kumar Acharya <sheggodu@redhat.com>
Date:   Wed Jun 14 16:28:40 2017 +0530

    cluster/ec: Implement DISCARD FOP for EC
    
    Updates #254
    
    This code change implements DISCARD FOP support for
    EC.
    
    BUG: 1461018
    Change-Id: I09a9cb2aa9d91ec27add4f422dc9074af5b8b2db
    Signed-off-by: Sunil Kumar Acharya <sheggodu@redhat.com>
Comment 19 Worker Ant 2017-11-29 02:37:09 EST
REVIEW: https://review.gluster.org/18885 (release-notes:  Add release notes for DISCARD FOP on EC) posted (#1) for review on release-3.13 by Sunil Kumar Acharya
Comment 20 Worker Ant 2017-11-29 09:38:03 EST
REVISION POSTED: https://review.gluster.org/18885 (release-notes:  Add release notes for DISCARD FOP on EC) posted (#2) for review on release-3.13 by Sunil Kumar Acharya
Comment 21 Shyamsundar 2017-12-08 12:33:42 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.13.0, please open a new bug report.

glusterfs-3.13.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-December/000087.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.