Bug 1461049 - SIGILL on _armv7_tick in libcrypto.so.1.1 when running vlc in gdb
SIGILL on _armv7_tick in libcrypto.so.1.1 when running vlc in gdb
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-13 08:30 EDT by Nicolas Chauvet (kwizart)
Modified: 2017-06-13 08:47 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-13 08:45:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2017-06-13 08:30:57 EDT
Description of problem:
Running vlc on f27 using wandboard quad (cortex-a9 with neon). and etnaviv shows the following error in gdb.

Version-Release number of selected component (if applicable):
libcrypt-nss-2.25.90-2.fc27.armv7hl

How reproducible:
always

Steps to Reproduce:
1. vlc on armv7
2.
3.

Actual results:
Cannot parse expression `.L1017 4@r4'.

Program received signal SIGILL, Illegal instruction
0xb52defa8 in _armv7_tick () from /lib/libcrypto.so.1.1


Expected results:
Play video.

Additional info:
# cat /proc/cpuinfo 
processor	: 0
model name	: ARMv7 Processor rev 10 (v7l)
BogoMIPS	: 6.00
Features	: half thumb fastmult vfp edsp thumbee neon vfpv3 tls vfpd32 
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x2
CPU part	: 0xc09
CPU revision	: 10

4.12.0-0.rc5.git0.1.fc27.armv7hl
Comment 1 Florian Weimer 2017-06-13 08:37:56 EDT
libcrypto (with an o) is part of openssl.
Comment 2 Tomas Mraz 2017-06-13 08:45:48 EDT
The openssl handles the SIGILL and uses it to test for the instructions present - this is not a bug.
Comment 3 Tomas Mraz 2017-06-13 08:47:43 EDT
If you have trouble running vlc outside the gdb it is probably irrelevant to this SIGILL.

Note You need to log in before you can comment on or make changes to this bug.