This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1461071 - Docker: Handling uid/gid on docker cp
Docker: Handling uid/gid on docker cp
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Antonio Murdaca
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks: 1186913 1477427
  Show dependency treegraph
 
Reported: 2017-06-13 09:05 EDT by Jaroslav Spanko
Modified: 2017-09-05 06:35 EDT (History)
7 users (show)

See Also:
Fixed In Version: docker-2:1.12.6-50.git0fdc778
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 06:35:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Spanko 2017-06-13 09:05:42 EDT
Description of problem:
Handle of uid/gid for docker cp and API

How reproducible:
Fully reproducable 

Actual results:
docker cp does not handle uid/gid of files

Expected results:
Handle uid/gid for docker cp and API

Additional info:
Upstream issue and pull which will be available in 17.06 most probably
https://github.com/moby/moby/issues/21651
https://github.com/moby/moby/pull/28923
Comment 2 Daniel Walsh 2017-06-30 11:35:26 EDT
Antonio are these something we should back port?
Comment 3 Antonio Murdaca 2017-07-10 07:21:44 EDT
Yes, we need to back port this one. Could you please provide the docker version of your docker so I know where to back port this? Thanks
Comment 6 Luwen Su 2017-08-25 04:06:57 EDT
In docker-1.12.6-55.gitc4618fb.el7.x86_64,

In VM,
# ll
total 4
-rw-rw-r--. 1 test test   0 Aug 25 15:44 test
-rw-rw-r--. 1 test test 106 Aug 25 15:44 test.tar.gz

Container inside:
-rw-rw-r--.   1 1000 1000  106 Aug 25 07:44 test.tar.gz

move to verified.
Comment 8 errata-xmlrpc 2017-09-05 06:35:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2599

Note You need to log in before you can comment on or make changes to this bug.