Bug 1461106 - Cockpit does not display containers graphs on bridge connection
Cockpit does not display containers graphs on bridge connection
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cockpit (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dominik Perpeet
qe-baseos-daemons
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-13 10:02 EDT by Jaroslav Spanko
Modified: 2017-06-19 07:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-16 08:51:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Spanko 2017-06-13 10:02:01 EDT
Description of problem:
On the direct cockpit instance on a server can see the CPU and memory usage of the docker containers 
If I use a bridge connection to the host the CPU and memory usage is not filled 

Version-Release number of selected component (if applicable):

cockpit-135-4.el7.x86_64                                                            
cockpit-docker-135-4.el7.x86_64                                                  
cockpit-system-135-4.el7.noarch                             
                       
How reproducible:
100%

Steps to Reproduce:
1. use bridge connection to the docker tab
2. graphs are empty, also usage for containers

Actual results:
CPU and memory usage are empty

Expected results:
Graphs will be presented

Additional info:
Snaps in attachements
Comment 3 Peter 2017-06-13 17:52:20 EDT
If by bridge you mean secondary server, then I am unable to reproduce. Are both servers running the same version of docker? Can you provide the OS and docker versions for the target. If you connect to the secondary server directly does the graph work then?
Comment 4 Jaroslav Spanko 2017-06-14 02:37:38 EDT
Hi Peter
Version are the same, RHEL 7.3 and docker 12.6-16
cockpit.x86_64        135-4.el7                                                               
cockpit-bridge.x86_64 135-4.el7                                                              
cockpit-dashboard.x86_64 135-4.el7                                                              
cockpit-doc.x86_64    135-4.el7                                                              
cockpit-docker.x86_64   135-4.el7                                                             
cockpit-kubernetes.x86_64    135-4.el7                                                               
cockpit-pcp.x86_64       135-4.el7                                                              
cockpit-storaged.noarch      135-4.el7                                                              
cockpit-system.noarch       135-4.el7                                                              
cockpit-ws.x86_64          135-4.el7   

I attached the direct screen.
If you need any logs please let me know
Thx
Comment 6 Jaroslav Spanko 2017-06-14 02:39:21 EDT
Also just for note not only graphs but also CPU and memory usage in Containers content is not filled so i would say is not parse for some reason in this case.
Comment 9 Ruben Romero Montes 2017-06-19 07:46:36 EDT
Closed as NOTABUG since upgrading to the latest release allows the graphs to be displayed properly.
 
  cockpit-docker-138-6.el7.x86_64
  cockpit-138-8.el7.x86_64

Note You need to log in before you can comment on or make changes to this bug.