Bug 1461131 - [RFE] gid is not found for volumes created using heketi-3
[RFE] gid is not found for volumes created using heketi-3
Status: ASSIGNED
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi (Show other bugs)
cns-3.6
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Raghavendra Talur
Rahul Hinduja
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-13 10:54 EDT by Raghavendra Talur
Modified: 2017-10-10 09:33 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Volumes that were created using CNS 3.5 or previous don't have the GID stored in heketi database. Hence, when a volume expansion is performed, new bricks don't get the group id set on them which might lead to I/O errors. To fix this please refer to the knowledge base article at:...
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Talur 2017-06-13 10:54:21 EDT
Description of problem:
If a volume was created using heketi 3.* version and then a volume expansion is performed then the new bricks won't acquire the gid of the volume.
Comment 2 Humble Chirammal 2017-06-15 01:34:14 EDT
Ragavendra, Do you plan to land the patch for gid collection in heketi via this bugzilla ? if yes, are we targetting it for CNS 3.6 ?
Comment 3 Humble Chirammal 2017-08-02 10:13:10 EDT
This is an RFE, so I am moving out of this release.
Comment 4 Prasanth 2017-10-04 13:06:44 EDT
Bhavana, this BZ should be documented as a known issue for CNS 3.6 release and so please do the needful.

Note You need to log in before you can comment on or make changes to this bug.