Bug 1461158 - Frequent "unable to confirm openshift-controller-manager lease exists" errors during cluster horizontal runs
Frequent "unable to confirm openshift-controller-manager lease exists" errors...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
3.6.0
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Clayton Coleman
Mike Fiedler
aos-scalability-36
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-13 12:54 EDT by Mike Fiedler
Modified: 2017-08-16 15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:28:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Origin (Github) 14662 None None None 2017-06-14 20:17 EDT

  None (edit)
Description Mike Fiedler 2017-06-13 12:54:40 EDT
Description of problem:

Cluster is HA:  3 master/etcd, 2 infra, 305 compute nodes

Workload is create 1K projects with 6K pods (4K running) + secrets, services, builds, image streams, etc.   Full project spec is here:  https://github.com/mffiedler/svt/blob/master/openshift_scalability/config/pyconfigMasterVirtScalePause.yaml


During project creation/scale up the following message 

 atomic-openshift-master-controllers: E0613 11:45:05.948563   68412 leaderelection.go:136] unable to confirm openshift-controller-manager lease exists: endpoints "openshift-controller-manager" not found

popped 14,720 times - more or less evenly spread across the masters.


Version-Release number of selected component (if applicable): 3.6.105


Additional info: 

I'll add full master log location information in a comment.
Comment 3 Maru Newby 2017-06-14 20:17:03 EDT
The logging is unnecessary and does not represent an error condition.  The linked GH issue stops logging this normal condition.
Comment 4 Maru Newby 2017-06-15 15:01:26 EDT
PR has merged.
Comment 6 Mike Fiedler 2017-07-05 10:43:36 EDT
Verified on 3.6.132
Comment 8 errata-xmlrpc 2017-08-10 01:28:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.