Bug 146117 - Libswt3-gtk2 package creates incorrect symlink on PowerPC
Libswt3-gtk2 package creates incorrect symlink on PowerPC
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Tromey
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-25 10:28 EST by W. Michael Petullo
Modified: 2014-08-11 01:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-29 15:43:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2005-01-25 10:28:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
The libbswt3-gtk2 package sets up the following symbolic link:

/usr/lib/java/swt-gtk-3.1M4.jar ->
/usr/share/eclipse/plugins/org.eclipse.swt.gtk*_3.1.0/ws/gtk/swt.jar

Notice the '*.'

The destination of this link should probably be
/usr/share/eclipse/plugins/org.eclipse.swt.gtk_3.1.0/ws/gtk/swt.jar in
the case of a 32-bit PowerPC platform.

Version-Release number of selected component (if applicable):
libswt3-gtk2-3.1-0.M4.19

How reproducible:
Always

Steps to Reproduce:
Try to build software that uses swt.jar.
    

Actual Results:  The build fails because of the invalid symbolic link
noted above.

Additional info:
Comment 1 Andrew Overholt 2005-03-29 15:05:19 EST
I think this is fixed now.  Is it still a problem for you?
Comment 2 W. Michael Petullo 2005-03-29 15:43:20 EST
This has been fixed.

Note You need to log in before you can comment on or make changes to this bug.