Bug 1461173 - [abrt] gnome-shell: meta_window_wayland_move_resize_internal(): gnome-shell killed by signal 8
[abrt] gnome-shell: meta_window_wayland_move_resize_internal(): gnome-shell k...
Status: CLOSED DUPLICATE of bug 1413766
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
26
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:0255b7210a39f20810a4edab6b2...
:
: 1546286 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-13 13:37 EDT by Jonathan Briggs
Modified: 2018-02-16 14:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-11 16:39:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (82.49 KB, text/plain)
2017-06-13 13:37 EDT, Jonathan Briggs
no flags Details
File: cgroup (373 bytes, text/plain)
2017-06-13 13:37 EDT, Jonathan Briggs
no flags Details
File: core_backtrace (35.45 KB, text/plain)
2017-06-13 13:37 EDT, Jonathan Briggs
no flags Details
File: cpuinfo (1.26 KB, text/plain)
2017-06-13 13:37 EDT, Jonathan Briggs
no flags Details
File: dso_list (25.79 KB, text/plain)
2017-06-13 13:37 EDT, Jonathan Briggs
no flags Details
File: environ (2.42 KB, text/plain)
2017-06-13 13:37 EDT, Jonathan Briggs
no flags Details
File: limits (1.29 KB, text/plain)
2017-06-13 13:37 EDT, Jonathan Briggs
no flags Details
File: maps (142.74 KB, text/plain)
2017-06-13 13:37 EDT, Jonathan Briggs
no flags Details
File: open_fds (8.73 KB, text/plain)
2017-06-13 13:37 EDT, Jonathan Briggs
no flags Details
File: proc_pid_status (1.29 KB, text/plain)
2017-06-13 13:37 EDT, Jonathan Briggs
no flags Details
File: var_log_messages (1.31 KB, text/plain)
2017-06-13 13:37 EDT, Jonathan Briggs
no flags Details

  None (edit)
Description Jonathan Briggs 2017-06-13 13:37:41 EDT
Description of problem:
Left the computer, the screen timeout locked the display. After attempting to unlock the screen with password, it crashed.

Version-Release number of selected component:
gnome-shell-3.24.2-1.fc26

Additional info:
reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: meta_window_wayland_move_resize_internal
executable:     /usr/bin/gnome-shell
journald_cursor: s=f26a41dd0046472c99b00b7ae7f2971e;i=13a5bf;b=cedb8d58b87d4d8388f0ba4cab480c1d;m=1129649ca;t=551da9473ec5d;x=5b87bd641e842e63
kernel:         4.11.4-300.fc26.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1001

Truncated backtrace:
Thread no. 1 (6 frames)
 #0 meta_window_wayland_move_resize_internal at wayland/meta-window-wayland.c:196
 #1 meta_window_move_resize_internal at core/window.c:3721
 #2 meta_window_move_resize_now at core/window.c:3917
 #3 idle_move_resize at core/window.c:3952
 #4 call_idle_later at core/util.c:864
 #10 meta_run at core/main.c:648
Comment 1 Jonathan Briggs 2017-06-13 13:37:46 EDT
Created attachment 1287409 [details]
File: backtrace
Comment 2 Jonathan Briggs 2017-06-13 13:37:47 EDT
Created attachment 1287410 [details]
File: cgroup
Comment 3 Jonathan Briggs 2017-06-13 13:37:48 EDT
Created attachment 1287411 [details]
File: core_backtrace
Comment 4 Jonathan Briggs 2017-06-13 13:37:49 EDT
Created attachment 1287412 [details]
File: cpuinfo
Comment 5 Jonathan Briggs 2017-06-13 13:37:50 EDT
Created attachment 1287413 [details]
File: dso_list
Comment 6 Jonathan Briggs 2017-06-13 13:37:51 EDT
Created attachment 1287414 [details]
File: environ
Comment 7 Jonathan Briggs 2017-06-13 13:37:52 EDT
Created attachment 1287415 [details]
File: limits
Comment 8 Jonathan Briggs 2017-06-13 13:37:54 EDT
Created attachment 1287416 [details]
File: maps
Comment 9 Jonathan Briggs 2017-06-13 13:37:55 EDT
Created attachment 1287417 [details]
File: open_fds
Comment 10 Jonathan Briggs 2017-06-13 13:37:56 EDT
Created attachment 1287418 [details]
File: proc_pid_status
Comment 11 Jonathan Briggs 2017-06-13 13:37:57 EDT
Created attachment 1287419 [details]
File: var_log_messages
Comment 12 Jonathan Briggs 2017-06-13 14:54:03 EDT
Looking at the back trace and the zero value for height, I believe this is related to how the Intel graphics and the external monitor interact on my system.

This monitor seems to need two or three tries to get the DP link stabilized at 4K@60Hz. It seems that gnome-shell is getting some of these intermediate failed states and trying to work with invalid data. It should probably ignore anything that claims the screen has suddenly become zero pixels in size.
Comment 13 Jonathan Briggs 2017-07-11 16:39:08 EDT

*** This bug has been marked as a duplicate of bug 1413766 ***
Comment 14 Tom Litton 2018-02-16 14:39:36 EST
*** Bug 1546286 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.