Bug 1461192 - AttributeError: 'module' object has no attribute 'wait_for_volume_resource_status'
AttributeError: 'module' object has no attribute 'wait_for_volume_resource_st...
Status: CLOSED DUPLICATE of bug 1441228
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest (Show other bugs)
11.0 (Ocata)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Chandan Kumar
Martin Kopec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-13 15:08 EDT by Dimitri Savineau
Modified: 2017-06-19 10:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-19 10:54:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitri Savineau 2017-06-13 15:08:15 EDT
Description of problem:

The cinder tempest test called 'cinder.tests.tempest.api.volume.test_volume_unicode.CinderUnicodeTest' [1] fails due to incompatibility between python-tempest and python-cinder-tests package version.

Version-Release number of selected component (if applicable):
RHOS 11 (Ocata)
python-cinder-tests-10.0.1-1.el7ost.noarch
python-tempest-15.0.0-2.el7ost.noarch
openstack-tempest-15.0.0-2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install tempest & cinder tests
2. Run cinder.tests.tempest.api.volume.test_volume_unicode.CinderUnicodeTest

Actual results:
{0} setUpClass (cinder.tests.tempest.api.volume.test_volume_unicode.CinderUnicodeTest) [0.000000s] ... FAILED
========================================
_StringException: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest/test.py", line 273, in setUpClass
    six.reraise(etype, value, trace)
  File "/usr/lib/python2.7/site-packages/tempest/test.py", line 266, in setUpClass
    cls.resource_setup()
  File "/usr/lib/python2.7/site-packages/cinder/tests/tempest/api/volume/test_volume_unicode.py", line 35, in resource_setup
    cls.volume = cls.create_volume_with_args(name=cls.volume_name)
  File "/usr/lib/python2.7/site-packages/cinder/tests/tempest/api/volume/test_volume_unicode.py", line 47, in create_volume_with_args
    waiters.wait_for_volume_resource_status(cls.volumes_client,
AttributeError: 'module' object has no attribute 'wait_for_volume_resource_status'

Additional info:

A commit has been backported in python-cinder-tests Ocata [2] but the associated code in python-tempest is only present since 16.0.0 (OSP12/Pike) [3]
This test is used in the cinder certification program for cinder volumes.

[1] https://github.com/openstack/cinder/blob/stable/ocata/cinder/tests/tempest/api/volume/test_volume_unicode.py
[2] https://github.com/openstack/cinder/commit/b05afc3fbae2c82f89c8f0bbda31c79169595fc6
[3] https://github.com/openstack/tempest/commit/52d7b0d62600b24f516070a4cc5f4194d5cffc76
Comment 1 Chandan Kumar 2017-06-13 15:15:41 EDT
FYI! Tempest-16.0.0 is tagged for OSP-11/ocata, will be available in OSP-11 z1 updates. Here is the BZ for the same: https://bugzilla.redhat.com/show_bug.cgi?id=1441228
Comment 3 Fabio Massimo Di Nitto 2017-06-19 10:54:21 EDT

*** This bug has been marked as a duplicate of bug 1441228 ***

Note You need to log in before you can comment on or make changes to this bug.