Bug 1461195 - Qt 5 applications Segmentation fault, from "/lib/libxcb.so.1"
Qt 5 applications Segmentation fault, from "/lib/libxcb.so.1"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qt5-qtbase (Show other bugs)
25
i386 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-13 15:16 EDT by Frank
Modified: 2017-07-18 07:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-18 07:48:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank 2017-06-13 15:16:29 EDT
Description of problem:

I installed "lazarus-1.6.2-1-fc25.i686", and after all QT applications stopped working with an error "Segmentation fault (`core' generado)" Example kolourpaint, megasync, vlc :

[mainadmin@fedoramd ~]$ kolourpaint
Segmentation fault (`core' generado)
[mainadmin@fedoramd ~]$

When I run a QT application, it stops and throws the error "Segmentation fault (`core' generado)".

When running a QT application from GDB you get the following error :

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

[mainadmin@fedoramd ~]$ gdb kolourpaint
GNU gdb (GDB) Fedora 7.12.1-48.fc25
Copyright (C) 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from kolourpaint...Reading symbols from /home/mainadmin/kolourpaint...(no debugging symbols found)...done.
(no debugging symbols found)...done.
Missing separate debuginfos, use: dnf debuginfo-install kolourpaint-16.12.3-1.fc25.i686
(gdb) start
Temporary breakpoint 1 at 0x20fb0
Starting program: /usr/bin/kolourpaint 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".

Temporary breakpoint 1, 0x80020fb0 in main ()
(gdb) c
Continuing.
[New Thread 0xb1d02b40 (LWP 3851)]
warning: Corrupted shared library list: 0x80160b20 != 0x80155cc0
[New Thread 0xb06beb40 (LWP 3852)]
[New Thread 0xafcffb40 (LWP 3853)]
[New Thread 0xaf4feb40 (LWP 3854)]
[New Thread 0xaeaffb40 (LWP 3855)]

Thread 1 "kolourpaint" received signal SIGSEGV, Segmentation fault.
0xb511eb39 in xcb_send_request_with_fds64 () from /lib/libxcb.so.1
(gdb) k
Kill the program being debugged? (y or n) y
(gdb) q
[mainadmin@fedoramd ~]$

:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::


The error stems from "/lib/libxcb.so.1".

Some QT applications like "k3b" do work.


I'm using :


Kernel-4.10.14

lazarus-1.6.2-1-fc25.i686

kolourpaint-16.12.3-1-fc25.i686

megasync-Fedora_25.i686

k3b.i686-1:2.0.3-11.fc25

gcc-6.3.1-1-fc25.i686


Version-Release number of selected component (if applicable):


How reproducible:

Install lazarus


Steps to Reproduce:

1.Install lazarus
2.Launch a QT application
3.Launch kolourpaint

Actual results:


Expected results:


Additional info:
Comment 1 Frank 2017-06-29 17:58:56 EDT
More information

I'm using

:::::::::::::::::::::::::::::::::::::::::::: 

NVIDIA Driver : 375.66

Server X11    : 11.0

GNOME         : Versión 3.22.2

::::::::::::::::::::::::::::::::::::::::::::

Important

I have installed:

 
qt.i686         4.8.7-18.fc25

qt5-qtbase.i686 5.7.1-16.fc25 


All qt-4.8.7 applications work.

Qt5 applications do not work.
Comment 2 Ngo Than 2017-07-18 07:48:18 EDT
i cannot reproduce this issue on f25 (i386) with intel graphic card and nvidia with nouveau drviver. It looks like a problem in binary only NVIDIA Driver which is not supported in fedora.

Please use nouveau driver in your case.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.