Bug 146129 - Interface eth0 will not start. Module natsemi.ko fails to bind network.
Interface eth0 will not start. Module natsemi.ko fails to bind network.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-25 11:38 EST by Rich Webb
Modified: 2015-01-04 17:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-17 11:28:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modules.conf, Jan 19 datestamp (341 bytes, text/plain)
2005-01-31 18:23 EST, Rich Webb
no flags Details

  None (edit)
Description Rich Webb 2005-01-25 11:38:42 EST
Description of problem: Network device eth0 will not start. Starting the network service 
results in errors: "bringing up interface eth0: natsemi: unknown parameter `irq'" and 
"Device eth0 has different MAC address than expected, ignoring." 

Version-Release number of selected component (if applicable): 2.6.10-1.741_FC3


How reproducible: Obseved on system boot and also on direct command to start 
networking service.


Steps to Reproduce:
1. # service network start
2. bringing up interface eth0: natsemi: unknown parameter `irq'
3. Device eth0 has different MAC address than expected, ignoring.

  Boot-time report is via ifup.
  
Actual results: Networking fails to initialize


Expected results: Network service active


Additional info:
1. Does not occur with prior FC3 releases, e.g., 2.6.10-1.737_FC3.
2. Affected device is reported as "National Semiconductor Corporation DP83815 
(MacPhyter) Ethernet Controller.
Comment 1 Brent Fox 2005-01-31 10:37:49 EST
Rich: can you post the contents of your /etc/modules.conf file?
Comment 2 Rich Webb 2005-01-31 18:23:06 EST
Created attachment 110468 [details]
modules.conf, Jan 19 datestamp

The /etc/modules.conf is attached. The changes from the (original?) Nov 11
version are adding the "alias usb-controller usb-ohci" line and the "options
natsemi irq=11" lines, plus the comment line re changes must be made to
modprobe.conf. In modprobe.conf, the only change wrt eth0 or the natsemi was to
move the "alias eth0 natsemi" from the first line under the opening comment to
the last line in the file.
Comment 3 Rich Webb 2005-02-03 13:00:20 EST
All appears well now with the 2.6.10-1.760_FC3 kernel: normal startup,
a happy network. Thanks!
Comment 4 Rob 2005-06-22 15:18:36 EDT
This sounds very similar to the problem I'm having.  I installed... FC4 was
looking nice...  Added my normal programs such as ICAclient and updated firefox
with some plugins.  I decided to reboot and BOOM!  When the system came up it
couldn't find the eth0 module.  I inserterd the module manually from
/lib/modules/* (modprobe eth0 doesn't work at this point).  Started the network
and continued to configure my system and found that there were many modules
missing.  The drivers for my usb mouse were present in /lib/modules* but were
not loaded by the kernel.  Also, file system modules such as smbfs and cifs were
not loaded.  There are others!!!  I believe this is a problem witht he kernel
for fc4.  I'll create a bug report for this issue.  FYI: This also happened with
the enterprise edition aka RHES 4
Comment 5 Dave Jones 2005-07-15 13:33:17 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 Rich Webb 2005-07-17 11:28:38 EDT
Interface eth0 starts correctly and successfully binds module natsemi.ko, in
released kernel versions except for release 2.6.10-1.741_FC3.

Works fine in kernel-2.6.12-1.1372_FC3. Status changed to resolved: WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.