Bug 1461290 - Review Request: gtk4 - GTK+ graphical user interface library
Review Request: gtk4 - GTK+ graphical user interface library
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Yanko Kaneti
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 03:08 EDT by Kalev Lember
Modified: 2017-08-17 13:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: gtk4-3.91.2-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-15 14:30:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
yaneti: fedora‑review+


Attachments (Terms of Use)

  None (edit)
Description Kalev Lember 2017-06-14 03:08:19 EDT
Spec URL: https://kalev.fedorapeople.org/gtk4.spec
SRPM URL: https://kalev.fedorapeople.org/gtk4-3.91.0-1.fc25.src.rpm
Description:
GTK+ is a multi-platform toolkit for creating graphical user
interfaces. Offering a complete set of widgets, GTK+ is suitable for
projects ranging from small one-off tools to complete application
suites.

This package contains version 4 of GTK+.

Fedora Account System Username: kalev
Comment 1 Kalev Lember 2017-06-14 04:18:45 EDT
Koji scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=20018909
Comment 2 Yanko Kaneti 2017-06-14 04:49:13 EDT
Naming's reasonable.
License like gtk3
Doesn't conflict except the -tests subpackage, which kalev will disable for now before importing

APPROVED


Not for future, should fix/split the gtk2-immodules(x86-64) is needed by gtk4-immodules-3.91.0-1.fc27.x86_64 thing
Comment 3 Kalev Lember 2017-06-14 04:52:07 EDT
Thanks Yanko!
Comment 4 Kalev Lember 2017-06-15 14:30:27 EDT
mclasen asked me to keep gtk4 out of rawhide for now until it gets closer to being ready for prime time. I'll skip importing it into git now but everything should be ready to go.

I'll close the ticket for now.
Comment 5 Kalev Lember 2017-08-17 13:48:45 EDT
OK, the builds are running for rawhide (F28) and F27 now.

Note You need to log in before you can comment on or make changes to this bug.