Bug 1461296 - Compilation doesn't work when using arm-none-eabi-gcc-cs on F26 Beta
Compilation doesn't work when using arm-none-eabi-gcc-cs on F26 Beta
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: arm-none-eabi-gcc-cs (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 03:23 EDT by p
Modified: 2017-07-20 11:52 EDT (History)
8 users (show)

See Also:
Fixed In Version: arm-none-eabi-gcc-cs-7.1.0-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1178520
Environment:
Last Closed: 2017-07-20 11:52:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description p 2017-06-14 03:23:04 EDT
+++ This bug was initially created as a clone of Bug #1178520 +++

Description of problem:
Compilation doesn't work.

Version-Release number of selected component (if applicable):
arm-none-eabi-gcc-cs-6.2.0-1.fc26.x86_64
arm-none-eabi-gdb-7.6.2-4.fc24.x86_64
arm-none-eabi-newlib-2.4.0-9.fc26.noarch
arm-none-eabi-binutils-cs-2.28-1.fc26.x86_64
arm-none-eabi-gcc-cs-c++-6.2.0-1.fc26.x86_64

How reproducible:
Always

Steps to Reproduce:
1. cat > test.c
int main(int argc, char *argv[])
{
  return 0;
}

2.arm-none-eabi-gcc -o test ./test.c

Actual results:
/usr/lib/gcc/arm-none-eabi/6.2.0/../../../../arm-none-eabi/bin/ld: cannot find crti.o: No such file or directory
/usr/lib/gcc/arm-none-eabi/6.2.0/../../../../arm-none-eabi/bin/ld: cannot find crtbegin.o: No such file or directory
/usr/lib/gcc/arm-none-eabi/6.2.0/../../../../arm-none-eabi/bin/ld: cannot find -lgcc


Expected results:
No error, compiled binary.
Comment 1 p 2017-06-14 13:40:17 EDT
I have manually updated the arm-none-eabi-gcc-cs package from f26's 6.2.0-1 to f25's 6.2.0-2.

like so:
dnf install http://mirrors.kernel.org/fedora/updates/25/x86_64/a/arm-none-eabi-gcc-cs-6.2.0-2.fc25.x86_64.rpm

For whatever reason after doing this version worked.

From the koji build list, it looks like version 6.2.0-3 has failed for f26.
Comment 2 Michal Hlavinka 2017-06-22 07:30:26 EDT
Every package release with release number "-1" is bootstrap package. It's not expected to work. This should not be present in updates repository. Seems f26 version of "-2" release is missing. I'll fix that.
Comment 3 Michal Hlavinka 2017-07-10 06:43:31 EDT
tested with arm-none-eabi-gcc-cs 7.1.0-2 (in the updates-testing, already) and it  works
$ arm-none-eabi-gcc test.c -lc -lnosys
Comment 4 Fedora Update System 2017-07-10 06:45:51 EDT
arm-none-eabi-gcc-cs-7.1.0-2.fc26 arm-none-eabi-newlib-2.5.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-7c933b4cd5
Comment 5 Fedora Update System 2017-07-20 11:52:17 EDT
arm-none-eabi-gcc-cs-7.1.0-2.fc26, arm-none-eabi-newlib-2.5.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.