Bug 1461316 - upstream ends in 2018
upstream ends in 2018
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grib_api (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On: 1508950
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 04:10 EDT by Jos de Kloe
Modified: 2018-04-29 16:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-29 16:52:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jos de Kloe 2017-06-14 04:10:49 EDT
Description of problem:

ECMWF has announced that it internally fully moved to the new ecCodes library now, and will only provide limited support for GRIB_API, e.g. tables and urgent bug fixes, but this will end in the autumn of 2018.
see: https://software.ecmwf.int/wiki/display/GRIB/Home

This seems a long time from now, but it may take some time to get ecCodes in Fedora. Are you already planning to package ecCodes anytime soon? If not, would you mind if I give it a try myself to package it?
Comment 1 Orion Poplawski 2017-06-16 18:37:57 EDT
I have an initial package:

https://www.cora.nwra.com/~orion/fedora/eccodes.spec
https://www.cora.nwra.com/~orion/fedora/eccodes-2.2.0-1.fc27.src.rpm

problem is that upstream doesn't understand sonames and refuses to do so: https://software.ecmwf.int/issues/browse/SUP-1809
Comment 2 Orion Poplawski 2017-06-16 18:38:24 EDT
Also, ENOTIME, so feel free to work on it.
Comment 3 Jos de Kloe 2017-06-17 04:58:21 EDT
Thanks.
They also don't understand transparancy in software development since I don't seem to have permission to view this issue.
Could you sumarise the sonames and ENOTIME problems here?
Comment 4 Jos de Kloe 2017-06-17 05:11:20 EDT
In addition the links to https://www.cora.nwra.com/ are not accessible to me.
Comment 5 Jan Kurik 2017-08-15 05:25:37 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 6 Fedora Update System 2018-04-19 09:07:55 EDT
eccodes-2.7.0-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2942160ff6
Comment 7 Fedora Update System 2018-04-19 21:49:21 EDT
eccodes-2.7.0-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2942160ff6
Comment 8 Fedora Update System 2018-04-29 16:52:54 EDT
eccodes-2.7.0-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.