Bug 1461322 - Support for fluentd running as root
Support for fluentd running as root
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine-metrics
Classification: oVirt
Component: Generic (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ovirt-4.1.3
: 1.0.4.3
Assigned To: Shirly Radco
Lukas Svaty
:
Depends On:
Blocks: oVirt-Metrics-and-Logs 1456459
  Show dependency treegraph
 
Reported: 2017-06-14 04:29 EDT by Sandro Bonazzola
Modified: 2017-07-06 10:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-06 10:01:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Metrics
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
lsvaty: testing_ack+


Attachments (Terms of Use)

  None (edit)
Description Sandro Bonazzola 2017-06-14 04:29:59 EDT
Latest version of fluentd is running with root privileges.
A simple fix for clean installations have been pushed to https://gerrit.ovirt.org/78140 but this won't probably cover upgrade scenario.
Please ensure upgraded systems still works with newest fluentd.
Comment 1 Sandro Bonazzola 2017-06-14 04:31:48 EDT
As a side note, we have OST performing upgrades from 4.0 and 4.1 to master but there's no testing of metrics on the upgraded system.
It may be worth to add metrics setup on 4.0/4.1 before upgrading and then again on the upgraded system.
Comment 2 Shirly Radco 2017-06-18 15:27:56 EDT
Is package fluentd-0.12.31 available in the upstream repos for master and 4.1.z?
Comment 3 Sandro Bonazzola 2017-06-19 07:27:33 EDT
For CentOS is in OpsTools testing: fluentd-0:0.12.31-4.el7.noarch

For Fedora a newer version is available since 4.1.0 GA: fluentd-0:0.14.8-1.fc24.noarch
Comment 4 Lukas Svaty 2017-06-22 06:18:49 EDT
waiting for new build, moving to modified
Comment 5 Lukas Svaty 2017-06-23 04:53:01 EDT
verified in ovirt-engine-metrics-1.0.4.3-1.el7ev.noarch

Note You need to log in before you can comment on or make changes to this bug.