Bug 1461337 - kernel-4.11.2..4 x64 fail to boot on Z77-Pro4 & I3-2120
kernel-4.11.2..4 x64 fail to boot on Z77-Pro4 & I3-2120
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
25
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 1461323 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 05:01 EDT by Cristian Sava
Modified: 2017-06-17 21:18 EDT (History)
10 users (show)

See Also:
Fixed In Version: kernel-4.11.5-200.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-16 14:52:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel-4.11.3-202.fc25.x86_64 fail to boot message (616.18 KB, image/jpeg)
2017-06-14 05:07 EDT, Cristian Sava
no flags Details

  None (edit)
Description Cristian Sava 2017-06-14 05:01:56 EDT
Description of problem: F25 updated kernel-4.11.x x64 does not boot on Asrock Z77-Pro4 & Intel I3-2120.
kernels 4.10.17 and 4.9.14 x64 are ok.

Version-Release number of selected component (if applicable):
F25 and F26 x64 kernels

How reproducible:Always. Same problem with F26 (live images tested)


Steps to Reproduce:
1. upgrade F25 x64 kernel to 4.11.x
2. reboot
3. select the new 4.11 kernel
4. fail to boot (stall with no message)

Actual results:
using earlyprintk=vga sched_debug:

Loading vmlinuz ... ok
Loading initrd.img ...
>>> stall with the photo image of the screen attached <<<

Fedora 25 or 26 live images (with kernel-4.11.x) also fail to boot
Same tests on Asrock Z97-Pro4 & I7-4790 succed

Expected results:
normal boot

Additional info:
I tried 4.11.2 ... 4.11.4 x64 kernels
Comment 1 Cristian Sava 2017-06-14 05:07 EDT
Created attachment 1287571 [details]
kernel-4.11.3-202.fc25.x86_64 fail to boot message
Comment 2 budious 2017-06-14 09:03:27 EDT
4.11.3-202.fc25.x86_64 does NOT boot at all for me either on similar hardware.

Recently upgraded from Fedora 24 to 25 and ran into same issue with Asrock P67 Extreme4 Gen3 with BIOS 2.20 (most recent from 2012). Xeon E3-1230v2 CPU.

If I remove "quiet" from the boot parameters, only the line "Probing EDD (edd=off to disable)... ok" appears. A blinking cursor appears directly below it and boot goes no further. nouveau is blacklisted.

Previous kernels 4.8.6-300.fc25.x86_64 and 4.10.10-100.fc24.x86_64 boot without issue.

There's also a recent support question on fedora question related to the kernel version and nouveau, which may be conflating multiple issues, but another user "nullcat" responding to thread posted his lspci which was similar to my hardware. We both have "Xeon E3-1200" processors. https://ask.fedoraproject.org/en/question/106433/kernel-panic-in-4113-using-nouveau-driver/

My hardware:
$ lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/Ivy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1c.6 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 7 (rev b5)
00:1c.7 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 8 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation P67 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port Desktop SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GP106 High Definition Audio Controller (rev a1)
03:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9120 SATA 6Gb/s Controller (rev 12)
04:00.0 USB controller: Etron Technology, Inc. EJ168 USB 3.0 Host Controller (rev 01)
05:00.0 USB controller: Etron Technology, Inc. EJ168 USB 3.0 Host Controller (rev 01)
06:00.0 PCI bridge: PLX Technology, Inc. PEX 8608 8-lane, 8-Port PCI Express Gen 2 (5.0 GT/s) Switch (rev ba)
07:01.0 PCI bridge: PLX Technology, Inc. PEX 8608 8-lane, 8-Port PCI Express Gen 2 (5.0 GT/s) Switch (rev ba)
07:04.0 PCI bridge: PLX Technology, Inc. PEX 8608 8-lane, 8-Port PCI Express Gen 2 (5.0 GT/s) Switch (rev ba)
07:05.0 PCI bridge: PLX Technology, Inc. PEX 8608 8-lane, 8-Port PCI Express Gen 2 (5.0 GT/s) Switch (rev ba)
07:06.0 PCI bridge: PLX Technology, Inc. PEX 8608 8-lane, 8-Port PCI Express Gen 2 (5.0 GT/s) Switch (rev ba)
07:07.0 PCI bridge: PLX Technology, Inc. PEX 8608 8-lane, 8-Port PCI Express Gen 2 (5.0 GT/s) Switch (rev ba)
07:08.0 PCI bridge: PLX Technology, Inc. PEX 8608 8-lane, 8-Port PCI Express Gen 2 (5.0 GT/s) Switch (rev ba)
07:09.0 PCI bridge: PLX Technology, Inc. PEX 8608 8-lane, 8-Port PCI Express Gen 2 (5.0 GT/s) Switch (rev ba)
09:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 01)
0a:01.0 Network controller: Ralink corp. RT3062 Wireless 802.11n 2T/2R
0c:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
Collapse All Comments
Expand All Comments
Add Comment
Unwrap comments
Show CC Changes
Comment 3 Laura Abbott 2017-06-14 11:24:05 EDT
Thanks for the screenshot, this looks like it was fixed via https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=792ef14df5c585c19b2831673a077504a09e5203

I'll drop this into the tree
Comment 4 Laura Abbott 2017-06-14 12:45:58 EDT
*** Bug 1461323 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2017-06-14 19:04:32 EDT
kernel-4.11.5-200.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c283e18644
Comment 6 Fedora Update System 2017-06-14 19:05:32 EDT
kernel-4.11.5-100.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c6974bc696
Comment 7 Fedora Update System 2017-06-14 20:10:54 EDT
kernel-4.11.5-300.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b09275041a
Comment 8 Cristian Sava 2017-06-15 00:04:11 EDT
(In reply to Fedora Update System from comment #5)
> kernel-4.11.5-200.fc25 has been submitted as an update to Fedora 25.
> https://bodhi.fedoraproject.org/updates/FEDORA-2017-c283e18644

It boots now on Asrock Z77-Pro4 & I3-2120
Congrats and thank you!
Comment 9 Fedora Update System 2017-06-15 06:57:17 EDT
kernel-4.11.5-100.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c6974bc696
Comment 10 Fedora Update System 2017-06-15 06:59:16 EDT
kernel-4.11.5-200.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c283e18644
Comment 11 Fedora Update System 2017-06-15 10:02:02 EDT
kernel-4.11.5-300.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b09275041a
Comment 12 Fedora Update System 2017-06-16 14:52:04 EDT
kernel-4.11.5-200.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2017-06-17 15:43:08 EDT
kernel-4.11.5-300.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2017-06-17 21:18:07 EDT
kernel-4.11.5-100.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.