Bug 146135 - Nautilus crashes when root mounts DVD's via CLI
Summary: Nautilus crashes when root mounts DVD's via CLI
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-25 17:11 UTC by Adam Bowns
Modified: 2013-03-06 03:42 UTC (History)
1 user (show)

Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-16 18:14:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Bowns 2005-01-25 17:11:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
If i burn a DVD+RW using growisofs then mount
it, as soon as the mount has finished, nautilus crashes. If restarted,
it continues to crash until the dvd is unmounted, at which point it
restarts and functions fine. Also, there is nothing wrong with the
DVD+RW. I can access it fine from the command line when it has been
mounted.

I reported this to bugzilla.gnome.org, and they have resolved it.
Could this resolution be included in a future package?

My origional report can be see at
http://bugzilla.gnome.org/show_bug.cgi?id=165134

and the resolution and proposed patch can be found at
http://bugzilla.gnome.org/show_bug.cgi?id=153888


Version-Release number of selected component (if applicable):
nautilus-2.8.1-4

How reproducible:
Always

Steps to Reproduce:
1.Burn dvd+rw using growisofs
2.Mount it

Actual Results:  Nautilus crashes

Expected Results:  Nothing to happen, I am not using nautilus to
access the DVD.

Comment 1 Michael A. Peters 2005-01-28 16:43:58 UTC
Experienced exact same behaviour with ISO 9660 DVD-R

burned
mounted as root via CLI (I don't automount)
nautilus crashed.

MD5SUM on the DVD of files on the DVD checks out.
This is new behaviour - it did not use to do this.

I will try mounting it as normal user and see what happens.
This is bad though.

Comment 2 Michael A. Peters 2005-01-28 16:46:44 UTC
update - ejected dvd
inserted into DVD-ROM drive
mounted as normal user - behaviour as expected (no crash nautilus)

Comment 3 Adam Bowns 2005-02-17 00:45:00 UTC
Yes, I can also confirm this. Mounting as normal user appears to work fine.

New steps to reproduce this bug are as follows:

1.At the command line Burn a dvd+rw using growisofs.
2.su -
3.Enter root's password.
4.mount /media/cdwriter

Results:
Nautilus crashes.

I have tried this in the same drive, with a ISO CD-ROM disk and I don't get the
problem. So it looks like the bug only effects DVD's.

Comment 4 Adam Bowns 2005-04-13 22:45:24 UTC
I have just come across some more info on this bug. If at the command line root
uses growisofs to burn a DVD+RW, ejects the DVD and reinserts it there is no
crash. The problem only seems to occur when root tries to mount a DVD
immediately after it has been written.

Comment 5 Adam Bowns 2005-07-05 14:46:58 UTC
Seems to be fixed in FC4. If anyone else can also confirm this Iâll close down
the bug.


Note You need to log in before you can comment on or make changes to this bug.