This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1461375 - SAGE | Contact U.S. | 8443134859 | Sage PeachTREE
SAGE | Contact U.S. | 8443134859 | Sage PeachTREE
Status: CLOSED NOTABUG
Product: Fedora Documentation
Classification: Fedora
Component: readme (Show other bugs)
devel
alpha All
unspecified Severity high
: ---
: ---
Assigned To: Paul W. Frields
Fedora Docs QA
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 06:29 EDT by jimmy
Modified: 2017-06-14 12:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-14 12:17:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jimmy 2017-06-14 06:29:05 EDT
Introduction

Explain one or two situations in which a user would need to use the process you will describe. Don’t explain the process here. The point of the introduction is to introduce the concepts the reader will put to use later, and to explain why it’s even useful to begin with.

Here’s a short example for an article about setting the hostname: “The computer’s hostname helps distinguish the system on a network. If you have appropriate privileges, you can set your system’s hostname to something that helps you identify it in your home or office network.”

If there’s anything the user needs to know in order to use the process, describe it here. For instance, in the hostname example, you would describe that only lowercase letters a-z, numerals 0-9, or the dash “-” may appear in a hostname. You might also tell them whether they need to be on a specific Fedora edition or version.

Running the most common process

Describe the process one step at a time. Describe the simplest and most common usage first. Assume the reader will try the first process they see.
https://blueprints.launchpad.net/adblockforchrome/+spec/bolggerboltahe
Use a graphical interface as the first and most common process. Document the default installation wherever possible. Use a screenshot, and don’t use your own customized user account. Use a fresh user account so it has a non-customized and stock appearance.

You may follow this case with a command-line equivalent in an additional section.

Running a more complex or less common process

You can describe a less common process as well. In this case, describe why it is useful. Be honest with yourself about whether this process is actually useful. Don’t use the article as a way of showing off your deep knowledge of a tool.

Conclusion

If there are common references, you can include them at the bottom. Do not point to dated information. Only use resources that are unlikely to change, are undated, or are well maintained.Fedora 25 is the first of the major Linux distros to employ the Wayland graphics stack by default.

Wayland is one of the biggest low-level changes to hit Linux distros in recent memory and what's most remarkable at least when it comes to Fedora 25 is the move is almost totally transparent. Provided your graphics card is supported, you're unlikely to even notice that you're using Wayland.

That's partly a testament to the Wayland project's efforts but also to Fedora in particular, a result of the Fedora developers' decision to wait before making the switch.
https://blueprints.launchpad.net/account-plugin-github/+spec/veryspeacialcharaterofthe-evening
It's been disappointing to see Wayland postponed time after time for the past few Fedora releases, but the waiting has paid off in stability and seamlessness.

I haven't hit any major bugs or had any apps that won't work (some of this is no doubt due to XWayland, which is the fallback X server that runs in situations where Wayland isn't supported). I have, on the other hand, noticed the default GNOME desktop in Fedora is considerably snappier, particularly animations.

That doesn't mean everything is perfect in the world of Wayland. I like to use Redshift or f.lux to tint-shift my screen at night as I find that much easier on my eyes. Neither application seems to work under Wayland thanks to changes in the security model of Wayland versus X.

Fortunately it seems Redshift-like features may be coming straight to GNOME itself. In the meantime, if you want to get tint-shifting working in Fedora 25 with GNOME, there's a COPR repo available that adds some new colour profiles to GNOME and a dawn/dusk timer to switch between them. There's some good instructions here.

Other than the tint-shift problem, my transition to Wayland has been smooth and largely uneventful. Some people with other graphic card/driver combos have reported problems with video playback but I haven't run into that in my testing (mplayer works fine on my Lenovo and a Dell XPS 13 I happened to be testing when Fedora 25 came out).

While the move to Wayland is definitely the big news in this release of Fedora, it's not the only thing that's new by any means. There's a major GNOME update, a brand new kernel and some changes in the Fedora Next lineup.

The most visually noticeable thing is the update to GNOME 3.22, which has some nice new features in the Files app (the application formerly known as Nautilus). There's a batch-renaming tool that makes it easy to add a prefix, suffix, or do date-based renaming of files. Files now includes a built-in file compression tool so when you double-click a .zip file it just extracts the contents to a folder without opening File Roller.https://blueprints.launchpad.net/bugzilla/+spec/moment-ago-after-service-project

This release also sees the GNOME extensions API being declared "stable". That's mostly good news for extension developers, but it also means that updates will no longer run the risk of breaking all the extensions you rely on to customise GNOME Shell.

The GNOME Software app continues to improve too. GNOME 3.22 sees Software adding better support for Flatpak apps. If you haven't had a chance to dive into the world of Flatpak apps yet, Fedora 25 makes a good platform to experiment on. Not only can you install Flatpaks using the GNOME Software app, with Fedora 25 you can even search or browse specifically for Flatpaks via Software. You'll now be able to see the source information and sandboxing status of Flatpaks before you install them.

Flatpaks are still a bit rough around the edges and the very tight sandboxing model that governs them can mean that Flatpak versions of your favourite apps are missing a few features, but they're getting closer to usable status.

The other big news in GNOME Software actually arrived in the previous Fedora release – system upgrades from the Software apps. I was able to upgrade from Fedora 24 to 25 by clicking a button in Software and everything just worked. Long-time Fedora users will know that this is nothing short of a miracle. I should note that I run a mostly stock install of Fedora with few GNOME extensions or other customisations. Most of the system update problems I've seen people mentioning on forums and bug reports around the web come from library conflicts so the more stuff you have installed the greater the chances GNOME Software won't work. Still, it's worth a try. From what I've seen, its one weak point is a lack of debugging messages when things do go wrong. If it doesn't work I'd jump over to the terminal and try using DNF to see what's causing the problem before you resort to the old Fedora nuke and pave upgrade path.

Along with Wayland and a new version of GNOME, this Fedora is notable for the update to Linux kernel 4.8.6, which should go a long way to fixing many of the Skylake bugs that cropped up with Fedora 24.

Note You need to log in before you can comment on or make changes to this bug.