Bug 1461390 - Segfault is QIcon destructor
Segfault is QIcon destructor
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qt5-qtbase (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 07:26 EDT by Remi Collet
Modified: 2017-07-19 15:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-19 15:35:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2017-06-14 07:26:23 EDT
Working on qelectrotech, we encouter segfault on app exit

(gdb) bt
#0  0x00007fdf53d07f73 in QIcon::~QIcon() () at /lib64/libQt5Gui.so.5
#1  0x00007fdf526f13d0 in __run_exit_handlers () at /lib64/libc.so.6
#2  0x00007fdf526f142a in  () at /lib64/libc.so.6
#3  0x00007fdf526d7408 in __libc_start_main () at /lib64/libc.so.6
#4  0x00005559f4cb509a in _start ()

Digging, this seems related to .svg file used in the application

Converting all .svg to .png avoid this segfault (but this look like a workaround)

Could be related to https://github.com/MaartenBaert/ssr/issues/508

Notice: this seems to be Fedora specific issue
(upstream cannot reproduce on Debian with Qt 5.7.1, Windows, MacOS...)


Reproduced on Fedora 25, 26 and RHEL-7

Application: https://qelectrotech.org/download.html
Source RPM: http://rpms.remirepo.net/SRPMS/qelectrotech-0.60~rc2-2.remi.src.rpm
(fedora only have 0.50 for now, which is not affected)
Comment 1 Ngo Than 2017-07-19 15:33:18 EDT
it's fixed in qt5-qtbase-5.7.1-19.fc25 which is pushed into f25 update testing today.

https://koji.fedoraproject.org/koji/buildinfo?buildID=920093

Note You need to log in before you can comment on or make changes to this bug.