Bug 1461412 - missing parameter in glance-api.conf for supporting Handle SSL termination proxies
missing parameter in glance-api.conf for supporting Handle SSL termination pr...
Status: CLOSED DUPLICATE of bug 1461358
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Cyril Roelandt
Mike Abrams
:
Depends On:
Blocks: 1451402
  Show dependency treegraph
 
Reported: 2017-06-14 08:13 EDT by Avi Avraham
Modified: 2017-06-14 09:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-14 09:45:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avi Avraham 2017-06-14 08:13:35 EDT
Description of problem:

Need to add the following parameter to /etc/glance/glance-api.conf

~~~~~~~
[DEFAULT]
secure_proxy_ssl_header = HTTP_X_FORWARDED_PROTO
~~~~~~~~

Version-Release number of selected component (if applicable):
python-glance-11.0.1-7.el7ost.noarch

How reproducible:


Steps to Reproduce:
1. grep secure_proxy_ssl_header /etc/glance/glance-api.conf
2.
3.

Actual results:
None 

Expected results:
#secure_proxy_ssl_header = NULL

Additional info:
Refer to rhos9 configuration for reference
Comment 1 Tzach Shefi 2017-06-14 09:45:11 EDT

*** This bug has been marked as a duplicate of bug 1461358 ***

Note You need to log in before you can comment on or make changes to this bug.