Bug 1461469 - OSError: Could not load UI file 'spokes/source.glade' for object 'SourceSpoke'
OSError: Could not load UI file 'spokes/source.glade' for object 'SourceSpoke'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Kolman
Fedora Extras Quality Assurance
:
: 1461824 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 09:55 EDT by Daniel Berrange
Modified: 2017-12-22 06:42 EST (History)
8 users (show)

See Also:
Fixed In Version: anaconda-27.13-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-22 06:42:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2017-06-14 09:55:36 EDT
Description of problem:
Launching Anaconda with the  2017-06-14 14:08    compose, pressing "Continue" on the first screen results in a traceback

Traceback (most recent call first):
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/__init__.py", line 180, in _findUIFile
    raise IOError("Could not load UI file '%s' for object '%s'" % (self.uiFile, self))
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/__init__.py", line 154, in __init__
    self.builder.add_objects_from_file(self._findUIFile(), self.builderObjects)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 59, in __init__
    GUIObject.__init__(self, data)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/installation_source.py", line 380, in __init__
    NormalSpoke.__init__(self, *args, **kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 141, in _createBox
    spoke = spokeClass(self.data, self.storage, self.payload, self.instclass)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 370, in refresh
    self._createBox()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/__init__.py", line 1031, in _on_continue_clicked
    nextAction.refresh()
OSError: Could not load UI file 'spokes/source.glade' for object 'SourceSpoke'


Version-Release number of selected component (if applicable):
27.12-1

How reproducible:
Always

Steps to Reproduce:
1. As root

$ virt-install --location https://www.mirrorservice.org/sites/dl.fedoraproject.org/pub/fedora/linux//development/rawhide/Server/x86_64/os/ --name f27x86_64 --file /var/lib/libvirt/images/f27x86_64.img --file-size 20 --ram 4000 --vnc --noautoconsole

2. Connect to VNC server with virt-viewer/virt-manager
3. Press "Continue" on first screen

Actual results:
Kaboom with above traceback.

Expected results:
Can carry on with installer

Additional info:
Comment 1 Martin Kolman 2017-06-14 11:46:03 EDT
Should be fixed by this PR:
https://github.com/rhinstaller/anaconda/pull/1098
Comment 2 Martin Kolman 2017-06-15 09:50:42 EDT
*** Bug 1461824 has been marked as a duplicate of this bug. ***
Comment 3 Jan Kurik 2017-08-15 04:11:46 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Note You need to log in before you can comment on or make changes to this bug.