Bug 1461534 - Setting VM ownership on more than 100 VMs at a time causing server error status 400 bad request
Setting VM ownership on more than 100 VMs at a time causing server error stat...
Status: ON_DEV
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.7.0
All All
high Severity high
: GA
: 5.7.4
Assigned To: Libor Pichler
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 13:36 EDT by Ryan Spagnola
Modified: 2017-08-18 07:23 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)
evm log (9.01 MB, application/x-xz)
2017-06-14 15:40 EDT, Ryan Spagnola
no flags Details

  None (edit)
Description Ryan Spagnola 2017-06-14 13:36:15 EDT
Description of problem:
Setting VM ownership on more than 100 VMs at a time causing  the following error:
Status 400 Bad Request
Content-Type
Data

Version-Release number of selected component (if applicable):
5.6.4

How reproducible:
Repeatedly

Steps to Reproduce:
1. Go To Compute > Infrastructure > Virtual Machines
2. list 100 items per page and check all
3. Go To Configuration > Set Ownership
4. Change Ownership and Group

Actual results:
400 Bad Request

Expected results:
Changed VM ownership

Additional info:
Tested in lab on vcenter provider with 10,000 vms. 
Changed ownership of 1,000 vms simultaneously without error.
Not able to reproduce on 5.6.4 or 5.7.2
Comment 2 Ryan Spagnola 2017-06-14 15:40 EDT
Created attachment 1287770 [details]
evm log

Note You need to log in before you can comment on or make changes to this bug.