Bug 1461578 - guides shipped with scap-security-guide use outdated template
guides shipped with scap-security-guide use outdated template
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: scap-security-guide (Show other bugs)
7.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Watson Yuuma Sato
BaseOS QE Security Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 16:20 EDT by Marek Haicman
Modified: 2018-03-23 14:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-23 14:22:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Haicman 2017-06-14 16:20:22 EDT
Description of problem:
Guides shipped in SCAP Security Guide, in directory /usr/share/doc/scap-security-guide-0.1.33/guides/ use older template, being generated by older openscap utility.

Version-Release number of selected component (if applicable):
scap-security-guide-0.1.33-5.el7.noarch

How reproducible:
reliably

Steps to Reproduce:
1. open any of the guides
2. check any rule with remediation
3.

Actual results:
Remediation is shown by default, remediation metadata are not present

Expected results:
Remediation is hidden behind "show" button. After clicking "show" button, remediation and it's metadata are displayed.

Additional info:
Comment 3 Marek Haicman 2018-03-23 14:22:12 EDT
Guides shipped in scap-security-guide-0.1.36-7.el7.noarch are build using openscap version 1.2.16, thus benefit from all aforementioned updates to the guide contents.

This is available in RHEL7.5 beta.

Note You need to log in before you can comment on or make changes to this bug.