Bug 146162 - RFE: remove the explicit kernel dependency
Summary: RFE: remove the explicit kernel dependency
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-25 18:55 UTC by Enrico Scholz
Modified: 2014-03-17 02:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 20:33:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2005-01-25 18:55:54 UTC
Description of problem:

Please remove the 'Requires: kernel >= 2.6' statement because it
bloats up minimal chroot installations.

As it is possible to have both a working kernel-2.4 and a kernel-2.6
package for testing purposes, the new initscripts could be installed
without problems. But when going back to 2.4, the system will fail to
boot as e.g. lvm does not work anymore.

Therefore, the dependency should be a 'Conflicts: kernel < 2.6' which
will signal in the situation above that kernel-2.4 is not supported.


Version-Release number of selected component (if applicable):

initscripts-8.04-1

Comment 1 Bill Nottingham 2005-01-25 19:51:30 UTC
Because various package updaters use install-not-upgrade for the
kernel,  this is problematic; it will break upgrades from a kernel 2.4
system.

Now, if we want to do that....

Comment 2 Warren Togami 2005-01-26 07:37:18 UTC
If it is impossible to remove this dep, we could instead use a bogus
virtual provides package for buildroots that satisfies this dep.
Provides: 999:kernel-999

Bad idea?

Comment 3 Bill Nottingham 2005-10-03 20:33:52 UTC
It's a conflicts ATM.


Note You need to log in before you can comment on or make changes to this bug.