Bug 1461645 - [Admin Portal] Uncaught exception occurred when deleting template from storage domain (related to delete protection?)
[Admin Portal] Uncaught exception occurred when deleting template from storag...
Status: VERIFIED
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-web-ui (Show other bugs)
4.0.6
Unspecified Unspecified
medium Severity medium
: ovirt-4.2.0
: ---
Assigned To: Tal Nisan
Raz Tamir
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 00:33 EDT by vaibhav
Modified: 2018-01-09 11:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
UI.log (52.21 KB, text/plain)
2017-06-15 00:38 EDT, vaibhav
no flags Details
Screenshot of the error pop-up when deleting a write-protected template (97.77 KB, image/png)
2017-09-03 11:10 EDT, Allon Mureinik
no flags Details

  None (edit)
Description vaibhav 2017-06-15 00:33:39 EDT
Description of problem:
Uncaught exception occurred when deleting template from storage domain. 

~~~~~~
2017-06-13 19:25:36,813 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-8) [] Permutation name: 48526BF4A45B24ED366586696A8D363E
2017-06-13 19:25:36,813 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-8) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: undefined
	at Unknown.Ev(webadmin-0.js@25078)
	at Unknown.Mv(webadmin-0.js@41)
	at Unknown.X7(webadmin-0.js@19)
	at Unknown.$7(webadmin-0.js@19)
	at Unknown.i7(webadmin-0.js@117)
	at Unknown.oq(webadmin-0.js@26)
	at Unknown.yq(webadmin-0.js@23798)
	at Unknown.Y2(webadmin-0.js@149)
	at Unknown.qq(webadmin-0.js@112)
	at Unknown.R9e(webadmin-0.js@964)
	at Unknown.z$e(webadmin-0.js@85)
	at Unknown.B0e(webadmin-0.js@46)
	at Unknown.Sx(webadmin-0.js@29)
	at Unknown.Wx(webadmin-0.js@57)
	at Unknown.eval(webadmin-0.js@54)
	at Unknown.OC(webadmin-0.js@20)
	at Unknown.v9e(webadmin-0.js@98)
	at Unknown.lvl(webadmin-0.js@10635)
	at Unknown.R9e(webadmin-0.js@582)
	at Unknown.z$e(webadmin-0.js@85)
	at Unknown.y$e(webadmin-0.js@60)
	at Unknown.z0e(webadmin-0.js@52)
	at Unknown.Sx(webadmin-0.js@29)
	at Unknown.Wx(webadmin-0.js@57)
	at Unknown.eval(webadmin-0.js@54)
Caused by: java.lang.ClassCastException
~~~~~~~~~

Version-Release number of selected component (if applicable):

RHEV 4.0.6 

Actual results:
uncaught exception

Expected results:
ui without uncaught exception popup

Additional info:
Comment 1 vaibhav 2017-06-15 00:38 EDT
Created attachment 1287904 [details]
UI.log
Comment 2 Allon Mureinik 2017-06-18 05:06:16 EDT
Tal, isn't this a dup of a bug we already have our sights on?
Comment 5 Tal Nisan 2017-06-18 06:15:59 EDT
Hard to tell, the logs are obfuscated, I'll try and reproduce in the meanwhile but vaibhav, can you please add logs after installing the symbols package?
Comment 6 vaibhav 2017-06-19 00:26:04 EDT
Hello Tal,

I tried to remove template from API and then I got the exact error message because of what it was failing. I disabled "Delete Protection" from database and tried to delete template so this time I didn't got any GUI error.

Command used to delete template :- 

~~~~~~~~~~~~~~~~~~~
[root@dhcp8-54 ~]# curl -k --request DELETE --header 'Version: 4' --header 'Accept: application/xml' --user 'admin@internal:redhat.com' https://dhcp8-54.gsslab.pnq.redhat.com/ovirt-engine/api/templates/67cef94c-0900-4b48-9a65-89349ebcb0f4
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<fault>
    <detail>[Cannot remove Template. Delete protection is enabled. In order to delete, disable Delete protection first.]</detail>
    <reason>Operation Failed</reason>
</fault>
~~~~~~~~~~~~~~~~~~~

I think the error in GUI should give error about "Delete protection"
Comment 7 Allon Mureinik 2017-09-03 11:10 EDT
Created attachment 1321525 [details]
Screenshot of the error pop-up when deleting a write-protected template

This seems to have been solved as part of the 4.2 GUI overhaul. Moving to MODIFIED.
Comment 8 Raz Tamir 2017-11-15 08:52:07 EST
Verified on ovirt-engine-4.2.0-0.0.master.20171113223918.git25568c3.el7.centos

No exception when deleting template - UI and API

Note You need to log in before you can comment on or make changes to this bug.