Bug 1461660 - collectd-5.7.1-4.fc27 FTBFS: Some plugins are missing dependencies (turbostat)
collectd-5.7.1-4.fc27 FTBFS: Some plugins are missing dependencies (turbostat)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: collectd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ruben Kerkhof
Fedora Extras Quality Assurance
https://apps.fedoraproject.org/kosche...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 02:10 EDT by Petr Pisar
Modified: 2017-06-15 10:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-15 10:36:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2017-06-15 02:10:33 EDT
collectd-5.7.1-4.fc27 fails to build in F27:

=== configuring in libltdl (/builddir/build/BUILD/collectd-5.7.1/libltdl)
configure: running /bin/sh ./configure --disable-option-checking '--prefix=/usr'  '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--program-prefix=' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib64' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/var/lib' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--disable-dependency-tracking' '--disable-silent-rules' '--without-included-ltdl' '--enable-all-plugins' '--disable-static' '--disable-apple_sensors' '--disable-aquaero' '--disable-barometer' '--disable-dpdkstat' '--disable-grpc' '--disable-intel_rdt' '--disable-lpar' '--disable-mic' '--disable-netapp' '--disable-oracle' '--disable-pf' '--disable-routeros' '--disable-sigrok' '--disable-tape' '--disable-tokyotyrant' '--disable-write_mongodb' '--disable-zone' '--with-java=/usr/lib/jvm/java/' '--with-python=/usr/bin/python3' '--with-perl-bindings=INSTALLDIRS=vendor' '--disable-werror' 'AR_FLAGS=-cr' 'build_alias=x86_64-redhat-linux-gnu' 'host_alias=x86_64-redhat-linux-gnu' 'CFLAGS=-O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic' 'LDFLAGS=-Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld' 'CXXFLAGS=-O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic' 'PKG_CONFIG_PATH=:/usr/lib64/pkgconfig:/usr/share/pkgconfig' --cache-file=/dev/null --srcdir=.
[...]
Configuration:
[...]
    tokyotyrant . . . . . no (disabled on command line)
    turbostat . . . . . . no (dependency error)
    unixsock  . . . . . . yes
[...]
configure: error: "Some plugins are missing dependencies - see the summary above for details"
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.8kJI5b (%build)

A difference between working and failing build root:

        libpcap-devel 	14:1.8.1-3.fc26 	> 	14:1.8.1-4.fc27
	python3-devel 	3.6.1-6.fc27 	> 	3.6.1-7.fc27
	postgresql-devel 	9.6.2-4.fc27 	> 	9.6.3-1.fc27
	mosquitto-devel 	1.4.11-1.fc27 	> 	1.4.11-2.fc27
	lvm2-devel 	2.02.171-1.fc27 	> 	2.02.171-2.fc27
	xen-devel 	4.8.1-2.fc27 	> 	4.8.1-3.fc27
	libcurl-devel 	7.54.0-4.fc27 	> 	7.54.0-5.fc27
	glib2-devel 	2.52.2-1.fc27 	> 	2.52.2-2.fc27
	libcurl 	7.54.0-4.fc27 	> 	7.54.0-5.fc27
	postgresql-libs 	9.6.2-4.fc27 	> 	9.6.3-1.fc27
	python2-libs 	2.7.13-7.fc27 	> 	2.7.13-9.fc27
	perl-PathTools 	3.63-367.fc26 	> 	3.67-1.fc27
	perl-Carp 	1.40-366.fc26 	> 	1.42-1.fc27
	pkgconf-pkg-config 	1.3.5-1.fc27 	> 	1.3.6-1.fc27
	lvm2-libs 	2.02.171-1.fc27 	> 	2.02.171-2.fc27
	device-mapper-devel 	1.02.140-1.fc27 	> 	1.02.140-2.fc27
	device-mapper-event-devel 	1.02.140-1.fc27 	> 	1.02.140-2.fc27
	python2 	2.7.13-7.fc27 	> 	2.7.13-9.fc27
	python3 	3.6.1-6.fc27 	> 	3.6.1-7.fc27
	libuuid-devel 	2.29.1-2.fc26 	> 	2.30-0.1.fc27
	xen-libs 	4.8.1-2.fc27 	> 	4.8.1-3.fc27
	system-python-libs 	3.6.1-6.fc27 	> 	3.6.1-7.fc27
	mosquitto 	1.4.11-1.fc27 	> 	1.4.11-2.fc27
	libblkid-devel 	2.29.1-2.fc26 	> 	2.30-0.1.fc27
	lvm2 	2.02.171-1.fc27 	> 	2.02.171-2.fc27
	python3-libs 	3.6.1-6.fc27 	> 	3.6.1-7.fc27
	perl-ExtUtils-ParseXS 	1:3.31-368.fc26 	> 	1:3.34-1.fc27
	libX11 	1.6.5-1.fc27 	> 	1.6.5-2.fc27
	systemtap-sdt-devel 	3.2-0.20170410git... 	> 	3.2-0.20170512git...
	libpcap 	14:1.8.1-3.fc26 	> 	14:1.8.1-4.fc27
	python3-rpm-generators 		> 	4.13.0.1-1.fc27
	coreutils 	8.27-8.fc27 	> 	8.27-9.fc27
	perl-Data-Dumper 	2.161-2.fc26 	> 	2.167-1.fc27
	gnutls-devel 	3.5.11-1.fc27 	> 	3.5.12-2.fc27
	libX11-devel 	1.6.5-1.fc27 	> 	1.6.5-2.fc27
	glib2 	2.52.2-1.fc27 	> 	2.52.2-2.fc27
	gnutls-c++ 	3.5.11-1.fc27 	> 	3.5.12-2.fc27
	device-mapper-event 	1.02.140-1.fc27 	> 	1.02.140-2.fc27
	libmount 	2.29.1-2.fc26 	> 	2.30-0.1.fc27
	xen-licenses 	4.8.1-2.fc27 	> 	4.8.1-3.fc27
	device-mapper-event-libs 	1.02.140-1.fc27 	> 	1.02.140-2.fc27
	libuuid 	2.29.1-2.fc26 	> 	2.30-0.1.fc27
	gnutls 	3.5.11-1.fc27 	> 	3.5.12-2.fc27
	libX11-common 	1.6.5-1.fc27 	> 	1.6.5-2.fc27
	libacl 	2.2.52-13.fc26 	> 	2.2.52-15.fc27
	device-mapper-libs 	1.02.140-1.fc27 	> 	1.02.140-2.fc27
	p11-kit-devel 	0.23.5-1.fc27 	> 	0.23.5-2.fc27
	GeoIP 	1.6.10-1.fc27 	> 	1.6.11-1.fc27
	perl-Term-ANSIColor 	4.06-2.fc26 	> 	4.06-3.fc27
	perl-Unicode-Normalize 	1.25-366.fc26 	> 	1.25-367.fc27
	device-mapper 	1.02.140-1.fc27 	> 	1.02.140-2.fc27
	perl-threads-shared 	1.55-2.fc27 	> 	1.56-1.fc27
	gnutls-dane 	3.5.11-1.fc27 	> 	3.5.12-2.fc27
	fedora-release 	27-0.1 	> 	27-0.2
	pkgconf-m4 	1.3.5-1.fc27 	> 	1.3.6-1.fc27
	libwebsockets 	2.1.1-1.fc27 	> 	2.2.1-1.fc27
	bluez-libs 	5.44-1.fc27 	> 	5.45-1.fc27
	freetype 	2.7.1-6.fc27 	> 	2.8-1.fc27
	libblkid 	2.29.1-2.fc26 	> 	2.30-0.1.fc27
	coreutils-common 	8.27-8.fc27 	> 	8.27-9.fc27
	pkgconf 	1.3.5-1.fc27 	> 	1.3.6-1.fc27
	curl 	7.54.0-4.fc27 	> 	7.54.0-5.fc27
	p11-kit-trust 	0.23.5-1.fc27 	> 	0.23.5-2.fc27
	fedora-repos 	27-0.1 	> 	27-0.2
	gnupg2 	2.1.20-2.fc27 	> 	2.1.21-2.fc27
	xorg-x11-proto-devel 	7.7-21.fc26 	> 	7.7-22.fc27
	libpkgconf 	1.3.5-1.fc27 	> 	1.3.6-1.fc27
	util-linux 	2.29.1-2.fc26 	> 	2.30-0.1.fc27
	kernel-headers 	4.12.0-0.rc0.git6.1.... 	> 	4.12.0-0.rc1.git1.1....
	fedora-repos-rawhide 	27-0.1 	> 	27-0.2
	system-python 	3.6.1-6.fc27 	> 	3.6.1-7.fc27
	mesa-libGL 	17.1.0-0.3.rc2.fc27 	> 	17.1.0-1.fc27
	p11-kit 	0.23.5-1.fc27 	> 	0.23.5-2.fc27
	libfdisk 	2.29.1-2.fc26 	> 	2.30-0.1.fc27
	acl 	2.2.52-13.fc26 	> 	2.2.52-15.fc27
	libsmartcols 	2.29.1-2.fc26 	> 	2.30-0.1.fc27
	ipcalc 	0.1.8-2.fc26 	> 	0.2.0-1.fc27
	mesa-libgbm 	17.1.0-0.3.rc2.fc27 	> 	17.1.0-1.fc27
	mesa-libEGL 	17.1.0-0.3.rc2.fc27 	> 	17.1.0-1.fc27
	mesa-libglapi 	17.1.0-0.3.rc2.fc27 	> 	17.1.0-1.fc27
Comment 1 Ruben Kerkhof 2017-06-15 10:36:33 EDT
Fixed in collectd-5.7.2-4.fc27

Note You need to log in before you can comment on or make changes to this bug.