Bug 1461664 - Redeploy etcd certificates failed when etcd is provided via system container
Redeploy etcd certificates failed when etcd is provided via system container
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jan Chaloupka
Gaoyun Pei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 02:18 EDT by Gaoyun Pei
Modified: 2017-08-16 15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:28:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2017-06-15 02:18:43 EDT
Description of problem:
Install etcd as system container, the service name will be etcd. But redeploy cert playbook was trying to restart etcd_container service since "is_containerized": true  detected.
https://github.com/openshift/openshift-ansible/blob/openshift-ansible-3.6.109-1/playbooks/common/openshift-etcd/restart.yml#L8


Version-Release number of selected component (if applicable):
openshift-ansible-3.6.109-1.git.0.256e658.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1.Install ocp-3.6 env on AtomicHost, enable etcd system container installed.
After installation, etcd service is running well
[root@qe-gpei-etcd-sc-4-etcd-1 etcd]# systemctl status etcd
● etcd.service - Etcd Server
   Loaded: loaded (/etc/systemd/system/etcd.service; enabled; vendor preset: disabled)
   Active: active (running) since Thu 2017-06-15 02:29:44 UTC; 3h 16min ago
 Main PID: 14193 (runc)
   Memory: 4.6M
   CGroup: /system.slice/etcd.service
           └─14193 /bin/runc --systemd-cgroup run etcd


2.Try to redeploy etcd cert with redeploy-etcd-certificates.yml playbook
ansible-playbook -i host /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/redeploy-etcd-certificates.yml


Actual results:
TASK [restart etcd] ************************************************************
fatal: [qe-gpei-etcd-sc-4-etcd-1.0615-re6.qe.rhcloud.com]: FAILED! => {
    "changed": false, 
    "failed": true
}

MSG:

Could not find the requested service etcd_container: cannot check nor set state


Expected results:


Additional info:
Comment 1 Jan Chaloupka 2017-06-20 06:07:18 EDT
https://github.com/openshift/openshift-ansible/pull/4504

Giuseppe, can you test it on AH?
Comment 2 Giuseppe Scrivano 2017-06-20 06:30:20 EDT
I've tested it on AH and it solves the problem for me.
Comment 4 Gaoyun Pei 2017-06-23 05:43:56 EDT
Verify this issue with openshift-ansible-3.6.123-1.git.0.0371aff.el7

When running redeploy-etcd-certificates.yml playbook against ocp-3.6 cluster with etcd running as system container, it could restart etcd service correctly.
Comment 6 errata-xmlrpc 2017-08-10 01:28:09 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.