Bug 1461671 - os-autoinst-4.4-18.20170410git97928a2.fc27 FTBFS: ./06-pod-coverage.t test fails
os-autoinst-4.4-18.20170410git97928a2.fc27 FTBFS: ./06-pod-coverage.t test fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: os-autoinst (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Williamson
Fedora Extras Quality Assurance
https://apps.fedoraproject.org/kosche...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 02:33 EDT by Petr Pisar
Modified: 2017-06-15 13:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: os-autoinst-4.4-19.20170410git97928a2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-15 04:31:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2017-06-15 02:33:48 EDT
os-autoinst-4.4-18.20170410git97928a2.fc27 fails to build in F27 because a test fails:

FAIL: 06-pod-coverage.t
=======================
not ok 1 - Everything in testapi covered
#   Failed test 'Everything in testapi covered'
#   at ./06-pod-coverage.t line 22.
#          got: undef
#     expected: '1'
# Uncovered: 
ok 2 - no (unexpected) warnings (via done_testing)
1..2
# Looks like you failed 1 test of 2.

This could be caused by perl-5.26.0 that does not have current working directory on standard Perl module search path.
Comment 1 Adam Williamson 2017-06-15 13:04:33 EDT
Thanks for the fix!

For future reference, I'm quite strict about 'upstream first' and clear documentation of patches: I never want a Patch line without (ideally) a link to an upstream commit or PR or (less ideally) a comment explaining why it cannot go upstream.

I'll submit your patch upstream, with attribution, and update the spec.
Comment 2 Adam Williamson 2017-06-15 13:17:50 EDT
https://github.com/os-autoinst/os-autoinst/pull/820

Note You need to log in before you can comment on or make changes to this bug.