Bug 1461687 - unable to remove octave-GeographicLib due to error in %preun
unable to remove octave-GeographicLib due to error in %preun
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: GeographicLib (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Rich Mattes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 03:53 EDT by George R. Goffe
Modified: 2017-07-08 18:20 EDT (History)
9 users (show)

See Also:
Fixed In Version: GeographicLib-1.48-2.fc27 GeographicLib-1.43-10.fc26 GeographicLib-1.43-7.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-08 12:49:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George R. Goffe 2017-06-15 03:53:28 EDT
Description of problem:
attempting to upgrade this system with the newest octave-GeographicLib but there  are already two versions on the system. It's %preun script(?) appears to be broken. rpm --nodeps -e octave-GeographicLib fails as well. is the --noscripts option the right thing to do in this case?

Version-Release number of selected component (if applicable):

rpm -qa | grep octave-GeographicLiboctave-GeographicLib-1.48-1.fc27.noarch
octave-GeographicLib-1.43-9.fc26.noarch

How reproducible:
always

Steps to Reproduce:
1.see below
2.
3.

Actual results:
see below

Expected results:

error free upgrade of this package.

Additional info:
dnf erase octave-GeographicLib-1.43-9.fc26.noarch
Waiting for process with pid 18318 to finish.
Dependencies resolved.
=======================================================================================================================================
 Package                                 Arch                      Version                           Repository                   Size
=======================================================================================================================================
Removing:
 octave-GeographicLib                    noarch                    1.43-9.fc26                       @rawhide                    154 k

Transaction Summary
=======================================================================================================================================
Remove  1 Package

Freed space: 154 k
Is this ok [y/N]: y
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                               1/1
  Running scriptlet: octave-GeographicLib-1.43-9.fc26.noarch                                                                       1/1
/var/tmp/rpm-tmp.KrggtB: line 7: /usr/share/octave/packages/%{octpkg}-1.43/packinfo/on_uninstall.m: No such file or directory
error: %preun(octave-GeographicLib-1.43-9.fc26.noarch) scriptlet failed, exit status 1
Error in PREUN scriptlet in rpm package octave-GeographicLib
Error in PREUN scriptlet in rpm package octave-GeographicLib
octave-GeographicLib-1.43-9.fc26.noarch was supposed to be removed but is not!
  Verifying        : octave-GeographicLib-1.43-9.fc26.noarch                                                                       1/1
There are:
  - 1 processes requiring reboot

For more information run:
    sudo tracer -iat 1497512586.0541713

Failed:
  octave-GeographicLib.noarch 1.43-9.fc26

Error: Transaction failed
fc27-bash 4.4 /export/home/porn/ashemaletube-models/adriana-bombom-1849# rpm --nodeps -e octave-GeographicLib-1.43-9.fc26.noarch
/var/tmp/rpm-tmp.tX6YWc: line 7: /usr/share/octave/packages/%{octpkg}-1.43/packinfo/on_uninstall.m: No such file or directory
error: %preun(octave-GeographicLib-1.43-9.fc26.noarch) scriptlet failed, exit status 1
error: octave-GeographicLib-1.43-9.fc26.noarch: erase failed
Comment 1 Orion Poplawski 2017-06-15 16:54:16 EDT
Yes, you'll need --noscripts at this point.  Problem is that %octave_pkg_preun requires the package to define %octpkg which GraphicsLib does not do.  I'll get a fix out shortly.
Comment 2 George R. Goffe 2017-06-16 03:19:56 EDT
Orion,

Cool. Thanks...

George...
Comment 3 Orion Poplawski 2017-06-16 10:40:31 EDT
This problem came in with 1.42-1.  But I don't know if it's okay to update older releases to 1.48.  I'll leave that decision up to the GeographicLib maintainers.
Comment 4 George R. Goffe 2017-06-16 11:06:56 EDT
Orion,

I tried to remove this pkg with "rpm --nodeps --noscripts -e octave-GeographicLib" and got error messages:

error: "octave-GeographicLib" specifies multiple packages:
  octave-GeographicLib-1.48-1.fc27.noarch
  octave-GeographicLib-1.48-1.fc27.noarch

I'm not sure what to do now. Any thoughts? Rebuild the rpm db? Try again after that?

Regards,

George...
Comment 5 Orion Poplawski 2017-06-16 11:11:09 EDT
Just remove the old one:

rpm --nodeps --noscripts -e octave-GeographicLib-1.43-9.fc26.noarch
Comment 6 George R. Goffe 2017-06-16 11:39:11 EDT
Orion,

The "old one" doesn't exist on this system.

# rpm -qa | grep octave-Geographiclib
octave-GeographicLib-1.48-1.fc27.noarch
octave-GeographicLib-1.48-1.fc27.noarch

# rpm --nodeps --noscripts -e octave-GeographicLib-1.48-1.fc27.noarch
error: "octave-GeographicLib-1.48-1.fc27.noarch" specifies multiple packages:
  octave-GeographicLib-1.48-1.fc27.noarch
  octave-GeographicLib-1.48-1.fc27.noarch

How does one get two packages on one system with the same name?

George...
Comment 7 Orion Poplawski 2017-06-16 11:48:16 EDT
That's beyond my experience.  Perhaps try rpm --rebuilddb?  After that I think you'll need to find some rpm experts.
Comment 8 George R. Goffe 2017-06-16 11:52:13 EDT
Orion,

I'll give that a try and report back here.

After that, I'll file a bug report for this situation if it still exists.

Thanks for your help,

George...
Comment 9 George R. Goffe 2017-06-16 16:18:01 EDT
Orion,

Rebuilding the rpm db did NOT affect this situation.

George...
Comment 10 George R. Goffe 2017-06-16 18:26:02 EDT
Orion,

Would you believe this command? dnf remove --duplicates FAILED as well.

The yum version of this command threw a stack trace. Sigh...

George...
Comment 11 Rich Mattes 2017-06-16 21:19:16 EDT
(In reply to Orion Poplawski from comment #3)
> This problem came in with 1.42-1.  But I don't know if it's okay to update
> older releases to 1.48.  I'll leave that decision up to the GeographicLib
> maintainers.

I read over the NEWS file, and it looks like there were some ABI changes between 1.42 and 1.48.  I think it's best to leave the stable branches at 1.42 in light of the stable upgrade guidelines.

I'll take care of adding %octpkg to f26, f25, and f24.
Comment 12 Fedora Update System 2017-06-16 21:56:45 EDT
GeographicLib-1.43-10.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d23f1624e5
Comment 13 Fedora Update System 2017-06-16 22:12:54 EDT
GeographicLib-1.43-7.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d545181220
Comment 14 Fedora Update System 2017-06-17 23:53:04 EDT
GeographicLib-1.43-7.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d545181220
Comment 15 Fedora Update System 2017-06-18 02:21:33 EDT
GeographicLib-1.43-10.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d23f1624e5
Comment 16 Fedora Update System 2017-07-08 12:49:57 EDT
GeographicLib-1.43-10.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2017-07-08 18:20:25 EDT
GeographicLib-1.43-7.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.