Bug 1461691 - [P9]Failed to run loadvm command
[P9]Failed to run loadvm command
Status: CLOSED DUPLICATE of bug 1457423
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.4-Alt
ppc64le Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Gibson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 04:21 EDT by Xujun Ma
Modified: 2017-06-21 07:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-15 23:05:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xujun Ma 2017-06-15 04:21:50 EDT
Description of problem:
Failed to run loadvm command

Version-Release number of selected component (if applicable):
host kernel:4.11.0-7.el7.test.ppc64le
guest kernel:4.11.0-5.el7.ppc64le
qemu-kvm-rhev-2.9.0-7.el7.ppc64le

How reproducible:
100%

Steps to Reproduce:
1.Boot up gues with command:
/usr/libexec/qemu-kvm \
 -name vm \
 -m 8192 \
 -rtc base=utc,clock=vm \
 -chardev stdio,mux=on,id=serial_id_serial0,server,nowait \
 -M pseries \
 -device spapr-vty,id=serial111,chardev=serial_id_serial0 \
 -mon chardev=serial_id_serial0,mode=readline \
 -nodefaults \
 -smp 4,maxcpus=4,cores=4,threads=1,sockets=1 \
 -device virtio-scsi-pci,bus=pci.0,addr=0x5 \
 -device scsi-hd,id=scsi-hd0,drive=scsi-hd-dr0,bootindex=1\
 -drive file=pegas.qcow2,if=none,id=scsi-hd-dr0,format=qcow2,cache=none \
 -device virtio-net-pci,netdev=net0,id=nic0,mac=70:e2:84:14:e7:84 \
 -netdev tap,id=net0,script=/etc/qemu-ifup,downscript=/etc/qemu-ifdown,vhost=on 
2.Run command savevm
(qemu)savevm 1
3.Run loadvm 1 after savevm
(qemu)loadvm 1

Actual results:
(qemu) loadvm 1
Failed to run loadvm command with error:
htab_load() bad index 2113929216 (6146+0 entries) in htab stream (htab_shift=0)
error while loading state for instance 0x0 of device 'spapr/htab'
Error -22 while loading VM state

Expected results:
Restore VM snapshot successfully without any errors.

Additional info:
ppc only
Comment 2 David Gibson 2017-06-15 23:05:50 EDT
Known problem with POWER9 RPT guests at the moment.  We can't savevm/loadvm or migrate.  Being worked upstream.

*** This bug has been marked as a duplicate of bug 1457423 ***

Note You need to log in before you can comment on or make changes to this bug.