Bug 1461701 - [RHEL 7.4]Missing new build boot entry after upgrade to rhvh-4.1-20170613.0
[RHEL 7.4]Missing new build boot entry after upgrade to rhvh-4.1-20170613.0
Status: CLOSED CURRENTRELEASE
Product: ovirt-node
Classification: oVirt
Component: Installation & Update (Show other bugs)
4.1
Unspecified Unspecified
unspecified Severity urgent (vote)
: ovirt-4.1.4
: 4.1
Assigned To: Ryan Barry
Huijuan Zhao
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 04:40 EDT by Huijuan Zhao
Modified: 2017-07-28 10:12 EDT (History)
15 users (show)

See Also:
Fixed In Version: imgbased-0.9.32-0.1.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-28 10:12:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: blocker+
cshao: testing_ack+


Attachments (Terms of Use)
All logs in /var/log, /tmp and sosreport from host (8.51 MB, application/x-gzip)
2017-06-15 04:40 EDT, Huijuan Zhao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78350 master MERGED osupdater: work around EL 7.4's lvm.conf changes 2017-06-22 12:29 EDT
oVirt gerrit 78542 ovirt-4.1 MERGED osupdater: work around EL 7.4's lvm.conf changes 2017-06-22 12:31 EDT

  None (edit)
Description Huijuan Zhao 2017-06-15 04:40:32 EDT
Created attachment 1287950 [details]
All logs in /var/log, /tmp and sosreport from host

Description of problem:
Missing new build boot entry after upgrade to rhvh-4.1-20170613.0

Version-Release number of selected component (if applicable):
From: redhat-virtualization-host-4.0-20170307.0
To:   redhat-virtualization-host-4.1-20170613.0

How reproducible:
100%

Steps to Reproduce:
1. Install rhvh-4.0-20170307.0
2. Login rhvh and setup local repos, upgrade to rhvh-4.1-20170613.0
   # yum update
3. Reboot and focus on boot entry

Actual results:
After step 3, missing new build boot entry, only one old build boot entry:
---------------------
rhvh-4.0-0.20170307.0
tboot 1.9.4
---------------------

Expected results:
After step 3,  should show both two build boot entry, just looks like.
---------------------
rhvh-4.1-0.20170613.0
rhvh-4.0-0.20170307.0
tboot 1.9.4
---------------------


Additional info:
No such issue in redhat-virtualization-host-4.1-20170609.2, so this is a regression bug.
Comment 1 Red Hat Bugzilla Rules Engine 2017-06-15 08:45:48 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Ryan Barry 2017-06-15 08:49:32 EDT
Since this is 7.4 only, we may want to move to 4.1.5
Comment 3 Ying Cui 2017-06-19 04:55:00 EDT
(In reply to Ryan Barry from comment #2)
> Since this is 7.4 only, we may want to move to 4.1.5

earlier is better to unblock RHVH 7.4 upgrade testing. Thanks.
Comment 4 Ryan Barry 2017-06-19 08:07:48 EDT
There will be a patch/build sooner. I just meant the targeted version.
Comment 5 Ryan Barry 2017-06-20 16:47:09 EDT
This is crazy --

The LVM team has made a breaking change in 7.4.

In 7.4, /etc/lvm/lvm.conf now defaults to "units = r"

If /etc is bind mounted from the 7.4 image to the 7.3 image (which imgbased does to do some fstab work), lvm commands immediately segfault with "Invalid Units Specification", even if "--units" is passed.

Instead, we must copy off the new LVM config, substitute the old, then copy the new one back once we're done.
Comment 6 Huijuan Zhao 2017-06-23 03:19:06 EDT
Test version:
From: redhat-virtualization-host-4.0-20170307.0
To:   redhat-virtualization-host-4.1-20170622.3(RHEL7.4)
      imgbased-0.9.32-0.1.el7ev.noarch

Test steps:
1. Install rhvh-4.0-20170307.0
2. Login rhvh and setup local repos, upgrade to rhvh-4.1-20170622.3
   # yum update
3. Reboot and focus on boot entry

Test results:
After step 3, there are both new and old build boot entries, can access new build successful.


So this bug is fixed in redhat-virtualization-host-4.1-20170622.3, I will change the status to VERIFIED after the status is changed to ON_QA.
Comment 7 Huijuan Zhao 2017-06-25 22:03:41 EDT
According to comment 6, change the status to VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.