Bug 1461702 - [trello yy3ACVjj]Should display new Bitbucket and Gitlab webhooks url on the bc configuration page
[trello yy3ACVjj]Should display new Bitbucket and Gitlab webhooks url on the ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jessica Forrester
XiaochuanWang
:
: 1464600 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 04:45 EDT by shahan
Modified: 2017-08-16 15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 10:03:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configuration tab (72.00 KB, image/png)
2017-06-15 04:45 EDT, shahan
no flags Details
unstable issue (1.99 MB, application/octet-stream)
2017-06-23 07:32 EDT, shahan
no flags Details

  None (edit)
Description shahan 2017-06-15 04:45:53 EDT
Created attachment 1287957 [details]
Configuration tab

Description of problem:
Should display new type webhooks url on the bc configuration page

Version-Release number of selected component (if applicable):
OpenShift Master:v3.6.109
Kubernetes Master:v1.6.1+5115d708d7 

How reproducible:
Always

Steps to Reproduce:
1.Login in web console 
2.Create an bc
# oc new-build openshift/ruby:latest --code=http://github.com/openshift/ruby-
hello-world.git
3.Go to ruby-hello-world bc edit page, add new type webhooks: add 'Bitbucket'  and 'Gitlab' webhooks under the drop-down list
4.Check Configuration tab of bc page

Actual results:
4.No display url of the new type webhooks and 'Lear more' link,It just display:
Other Trigger:GitLab/ Other Trigger:Bitbucket

Expected results:
4.Should display the URL and 'learn more' link as Github/Generic webhooks

Additional info:
Comment 1 Jessica Forrester 2017-06-15 13:25:13 EDT
This is being fixed in https://github.com/openshift/origin-web-console/pull/1720

It will properly display the webhook URLs for the new types now.  Instead of having a bunch of individual learn more links, which looked cluttered, we decided to have the Learn More link move up to the Triggers header and point to the build triggers page.
Comment 2 openshift-github-bot 2017-06-16 10:01:01 EDT
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/287fb70d559f9e0b7082a24a6bb3113a7ef48005
Bug 1461702 - Fix display of build webhooks to support new types

Also fixes outdated documentation links.
Comment 3 shahan 2017-06-21 04:09:18 EDT
Checked this issue in openshift v3.6.121, the bug was fixed. After add new Bitbucket and Gitlab webhooks, could display these webhooks url and just have Learn more link beside the Triggers header. So, could you change this bug status to ON_QA? Thanks!
Comment 5 shahan 2017-06-23 07:23:34 EDT
 The issue is indeed verified in the last comment, but found the new unstable issue: after adding some webhooks in BC editor, the Configuration tab sometimes can show triggers correctly but sometimes cannot. E.g. add Bitbucket webhook, Save, check Configuration tab, it is correct. Add another Github webhook, Save, check Configuration tab, it is wrong now. See video record
Comment 6 shahan 2017-06-23 07:32 EDT
Created attachment 1290980 [details]
unstable issue
Comment 7 Jessica Forrester 2017-06-23 12:42:53 EDT
New issue fixed in https://github.com/openshift/origin-web-console/pull/1763
Comment 8 Jessica Forrester 2017-06-26 08:11:01 EDT
*** Bug 1464600 has been marked as a duplicate of this bug. ***
Comment 10 shahan 2017-06-28 22:41:27 EDT
Test this issue against openshift v3.6.126.1, it was fixed. Besides, checked other add/remove orders, feature works well.

Note You need to log in before you can comment on or make changes to this bug.