Bug 1461767 - Trying to resize xfs filesystem without libguestfs-xfs installed fails with no warning or error message.
Trying to resize xfs filesystem without libguestfs-xfs installed fails with n...
Status: CLOSED DUPLICATE of bug 1204063
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 05:39 EDT by Juan Jimenez
Modified: 2017-06-15 05:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-15 05:56:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Jimenez 2017-06-15 05:39:31 EDT
Description of problem:

If I have an image that is being expanded, and I want to expand an xfs filesystem in the process, but libguestfs-xfs is not installed, the expansion fails witb no warning or error message.

Version-Release number of selected component (if applicable):

virt-resize 1.28.1

How reproducible:

Double the size of a working image into a new image file, then try to resize both the vdisk and the root filesystem.

Steps to Reproduce:
1. qemu-img create -f qcow2 -o preallocation=metadata <new_image>.qcow2 32G
2. virt-resize --expand /dev/sda2 --LV-expand /dev/centos/root  <old_image>.qcow2 <new.image>.qcow2

Actual results:

Device image expanded, filesystem specified does not change.

Expected results:

Device image expanded, filesystem also expanded.

Additional info:

Resolution is to install libguestfs-xfs but should give error or warning if not installed.
Comment 1 Pino Toscano 2017-06-15 05:56:07 EDT
Since virt-resize 1.31.21 there is a new option --unknown-filesystems to tweak the behaviour of virt-resize when resizing filesystems without a known method to expand them (possibly because the tools for it are missing).
The option takes three values:
- ignore: do nothing, not even print any message
- warn: do not expand, but print a warning message about the unexpanded filesystem
- error: error out when trying to expand a filesystem without valud method for it

The default is "warn", so it means you will see a warning by default.
Comment 2 Pino Toscano 2017-06-15 05:58:33 EDT
Ah, I missed this was already reported as bug 1204063.

*** This bug has been marked as a duplicate of bug 1204063 ***

Note You need to log in before you can comment on or make changes to this bug.