Bug 1461771 - [trello GwTNlzJ6] Add-to-Project directs to wrong page when choose Browse Catalog for project
[trello GwTNlzJ6] Add-to-Project directs to wrong page when choose Browse Cat...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jessica Forrester
XiaochuanWang
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 05:48 EDT by XiaochuanWang
Modified: 2017-08-16 15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 10:03:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description XiaochuanWang 2017-06-15 05:48:49 EDT
Description of problem:
When user choose Browse Catalog for "Add to Project", page directs to wrong page.

Version-Release number of selected component (if applicable):
OpenShift Master:    v3.6.109

How reproducible:
Always

Steps to Reproduce:
1. Create a project, click "Add to Project" in the right of page header
2. Hit "Browse Catalog"

Actual results:
Page goes to https://xxx:8443/console/

Expected results:
Should open the overlay panel (new design merged since v3.6.107-1)

Additional info:
Comment 1 Jessica Forrester 2017-06-15 10:17:56 EDT
That is the correct behavior for Browse Catalog, the whole point is that it is taking you to the new catalog to browse and find things you can add to your project. The overlay panel should only be opened for Deploy Image and Import YAML
Comment 2 XiaochuanWang 2017-06-15 22:05:19 EDT
It makes sense in this scenario, but if user click "Add to Project" button for an empty project from the center of the page instead of top header. The "Browse Catalog" page is still in the old layout, URL is also the same "https://hxxx:8443/console/project/<project>/create?tab=fromCatalog"
So are both layouts are the expected?
Comment 3 Jessica Forrester 2017-06-15 22:14:45 EDT
Ah yep that is a bug. Will need to decide what the right behavior should be when you hit that button in the empty project. Reducing the severity of this since it's only doing the wrong thing in the tech preview experience.
Comment 4 Jessica Forrester 2017-06-16 12:16:00 EDT
We decided to switch the button to "Browse Catalog" when the new experience is enabled, and the button will take you to the new catalog page.

https://github.com/openshift/origin-web-console/pull/1729
Comment 5 openshift-github-bot 2017-06-16 14:37:36 EDT
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/cfaffcd957d572b65795eff94ad803597dce6661
Bug 1461771 - Switch empty project Add to Project to Browse Catalog
Comment 6 shahan 2017-06-21 02:19:40 EDT
Checked this issue on openshift v3.6.121, it was already fixed, could you change the bug status to ON_QA? Thanks!

Note You need to log in before you can comment on or make changes to this bug.